1

To clarify, the USB port once worked, but I think I've borked it.

I have a Raspberry Pi Zero W. Been working great and I'm using it for a Game Boy Zero project, so loaded RetroPi on an SD card and have been using a micro USB hub to connect a variety of peripherals for testing (keyboard, xbox controller, Teensy Board for Game Boy interface, etc). It was all working great until (I think) shorted something when trying to externalise the USB port on the Pi (read: attempting to connect USB devices by soldering to the underside pads, bypassing the physical USB port).

The HDMI output went black, and I wasn't able to get an output for about 5 minutes and thought I'd fried the board. After I desoldered all the external attachments to the board (including the USB and the external power connection I had attached to an Adafruit Powerboost 1000C / Li Po battery), I still wasn't able to get an output at first, but it did come back and booted as normal as I can tell.

What hasn't come back is the USB port. My hub connected to the Pi is still lighting its power LED, suggesting it's getting at least some power, but any peripheral connected to it is not working (keyboard and xbox controller). Both the keyboard and controller are also not appeared to be powered, as the xbox center button is not lighting, and the caps/num/scroll lock LEDs are also not lighting when toggled.

What I think has happened

Doing some Googling, it appears that at least some generation of the Pi (not sure if mine included) have polyfuses, which appear to take a long time to reset (hours, days, maybe even weeks). So I'm hopeful that it will come back in time.

What I've tried

Unfortunately I don't have any input devices with micro USB, so I'm unable to test a peripheral straight to the Pi (skipping the hub) which would be my first step. I have tested the hub with an old phone which uses a micro USB port, and can confirm the hub works fine (the keyboard connected allowed me to type on the phone, also the caps/num/scroll LEDs work (the xbox controller, when plugged in, also lights its center LED, but I didn't try to use it with the phone)). Therefore I know the hub and peripherals still work fine. I've ordered a USB-A to micro USB converter so that I can test direct 'keyboard to Pi', but that'll be a number of days until I receive it.

Due to the polyfuse being my number 1 suspect I've disconnected the Pi and will wait until tomorrow to try again. If that still fails I'll try again a few days after that.

I'd appreciate any suggestions on what I can do to troubleshoot this. I seen some posts where they've measured the resistance of the polyfuse to determine its state, which I'll be doing over the next week. However, other than that I'm out of ideas. Am I not thinking of something simple I can try? Does my specific Pi not have a polyfuse and waiting is pointless?

Thanks in advance. If you need any clarification feel free to ask.

UPDATE: It appears that the Zero does not have a polyfuse. 20 hours later and it's still not working (understandably with no polyfuse). Any troubleshooting or diagnosing suggestions would be appreciated, otherwise I guess I'll have to buy another Zero.

1

The polyfuse would only protect the 5V rail, nothing else, especially not data lines and their drivers.

You may have damaged the USB data lines, for instance by shorting them to +5V (Vcc) or ground (GND). If you manged to also engage the 5th pin for OTG detection you may have caused the USB electronics in the BroadCom SoC to switch into USB host mode, and thus trying to drive the data lines, potentially causing damage to the data line drivers when the signal lines are shorted to Vcc or GND. The +5V (Vcc) rail polyfuse doesn't protect the USB data line drivers.

Personally, at around €10 for the Pi Zero W I would call the fried one, well, fried and move on to a new one. Your mileage may vary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.