1

I want to play videos, located on an USB disk which is connected via a powered USB hub, on my iPad(s). I converted these videos from .MKV to M4V (H264 codec) with HandBrake on Windows 7 using the universal setting. I installed MiniDLNA on the Raspbian (NOOBS) build. When I connect the Raspberry Pi (512) via the LAN; I am able to play the files correctly using ACE Player on the iPad (including language switching and build in subs). I can even play two different videos on two iPads at the same time. Trying to play the same video over Wifi (Raspberry Pi configured as an Access Point; iPad connecting to this AP), the video tries to load and then it doesn't play.

Trying an AVI-video based on FFMPEG works in both LAN and Wireless setups, but in this case I can only play one video at the time.

Is this an issue with the TCP stack for wireless, is it related to my WiFi dongle; or do I need to tweak/tune something?

I was hoping to use the configuration in the car; have the kids watch some videos when going on holiday. I have an iPad 1 and an iPad 3 to 'service'.

It seems to be working now.... In Ace Player on the iPad I configured to use QuickTime. When I switch that off, it plays the movies that it did not before! Will test some more and update.

  • Are the iPad getting an IP from the Pi? i.e. do you have a dhcp server running on the pi? – Gerben Jun 17 '13 at 11:39
  • Can you let us know a bit more about how you configured the AP. And the DHCP might be a valid point- but you said avi works so it must have IP. It should play normally over Wifi- there is no known problem with the TCP stack specifically for mp4-infact it works really good! Can you also put in the wifi dongle you are using and the power supply. Maybe some power/network problems when trying to read the mp4 file with usb Wifi. – Piotr Kula Jun 17 '13 at 15:39
  • The videos are on a USB hard drive, connected to the Pi via a powered hub, right? And while you can play two different videos on the two iPads, trying to play the same video on the two iPads fails? Sounds like the DLNA server is locking the files and allowing only one playback stream. – Jim Green Jun 17 '13 at 16:38
  • @Gerben.. Yes DHCP is working. – Arnold Jun 21 '13 at 17:50
  • @ppumkin.. I followed the guide from raspberry-at-home.com/hotspot-wifi-access-point. My dongle is a TPLINK TL-WN723NV2. The dongle and the WD 500GB NTFS disk is connected to a 7-port Perimac hub using a 3A power supply. The Raspberry is also powered by this hub, but I tried powering the Raspberry from its own power supply as well, with the same result. – Arnold Jun 21 '13 at 18:03
1

Changing the option in ACE Player (not using QuickTime) solved the issue. I can now stream two movies (H264 codec; M4V or MP4) to two iPads concurrently. I tried the setup in the car today and it works beautifully.

  • Which option did you change in ACE? – user13692 Mar 23 '14 at 19:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.