0

I have a pi sd card with raspbian on it. The version of the Raspberry Pi I am using is the Pi B 2 When I tried to boot it up with a normal power supply (micro-usb) it started to boot fine, but it got stuck on a blinking cursor after saying something about the wpa_supplicant daemon failed. Then I unplugged the pi and tried again, but this time I bent the power-supply cord near where the micro-usb end is. When I plugged it in after the wiggle, it booted fine and I could log in and pull up the desktop. I don't know why this happened, so is it a problem with the power-supply or the wpa_supplicant?

  • Is there a tiny yellow lightning flash symbol in the upper right corner of the screen? If yes, then the Pi complains about too low voltage. If it flickers, it's too low voltage at high power demand (e.g. Wifi) only. This can be caused by broken cables. – Janka Mar 11 '18 at 19:15
  • I don't think there was, but I will check. – Mooshroom14 Mar 12 '18 at 20:04
  • I worked with an embedded device that would support the keyboard and mouse through a mini-USB connector and it would easily break... So for my Raspberry Pi 3 I got a power supply with a switch on the cable so that way I won't have to plug/unplug all the time. Side note: if the system was doing work when you just unplugged, it can corrupt your drive data. – Alexis Wilke Mar 13 '18 at 7:16
  • When i unplug the cord it is just hanging at the same lines. – Mooshroom14 Mar 13 '18 at 14:14
  • Try to avoid just unplugging the cord without a proper shutdown; this is what leads to SD card corruption. – goldilocks Mar 27 '18 at 16:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.