0

I got a Raspberry Pi 3 yesterday and installed it with the default Raspbian OS (a.k.a. Debian) and tested the glxgears program to see how good (or bad) the OpenGL/3D support was.

For some reasons, I was thinking that the motherboard included some form of GPU when in fact it generates all the 3D rendering using the CPU and its NEON coprocessor (equivalent of SIMD on an Intel.) Don't get me wrong, NEON is great, but compared to a hardware GPU... you know...

The glxgears barely makes it in 30 FPS at the default size, but the colors are all wrong. The large gear flashes between red and orange. I've made a video on YouTube.com to show what I'm talking about (poor quality, but I think we can see the flashing going on):

https://youtu.be/mkBr5aQfxtI

What I'm wondering is: Is this the expected results as of Mar 12, 2018?

I read that the OpenGL driver is still being worked on, but I did not expect that something as "basic" as the glxgear would not be working better yet. (i.e. why would you release such a version to the public?)

4

You need to enable the OpenGL driver:

From a terminal window enter

sudo raspi-config

Then select 'Advanced Options','GL Driver','GL (Full KMS)'

Once you've rebooted glxgears should run at close to 60fps with the correct colours.

  • 3
    I'm shocked how easy one could google this. – Janka Mar 13 '18 at 14:20
  • Fantastic! :-) @Janka I did not look at the console configs, only the UI ones and that flag is not included. Also I searched and I could not find any information about a hardware GPU. What is the GPU? Is there one? – Alexis Wilke Mar 14 '18 at 0:58
  • 1
    read @Janka comment before asking about the GPU. – jsotola Mar 14 '18 at 2:31
  • The original Raspberry Pi has a BCM2835 SoC with two cores. One is used as the GPU, another ARM1176 core as the CPU. The GPU core runs a firmware from the config partition on the SD card. See docs.broadcom.com/docs/12358545 for documentation. The Pi3 has the same core for the GPU functions, plus four A53 ARM cores instead of the ARM1176 core. – Janka Mar 14 '18 at 7:54
0

Had to change resolution manually if using full drivers (added "video=1280x720@60" to cmdline.txt) and changed video ram to 256.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.