1

I would like to connect to my raspberry pi 3 through wifi, I have configured a static ip to wifi and disabled dhcp client.

When I tried to connect I get a following error:

ssh pi@192.168.1.109
pi@192.168.1.109's password: 

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Thu Mar 15 13:34:15 2018 from 192.168.1.121
-bash: gconv_builtin.c:71: __gconv_get_builtin_trans: Assertion `cnt < sizeof (map) / sizeof (map[0])' failed.
Connection to 192.168.1.109 closed.

How can I fix it?

UPDATE:

my relevant auth.log:

Mar 16 16:03:32 localhost systemd-logind[495]: New session c1 of user pi.
Mar 16 16:03:32 localhost systemd: pam_unix(systemd-user:session): session opened for user pi by (uid=0)
Mar 16 16:03:32 localhost sshd[823]: Received disconnect from 192.168.1.122: 11: disconnected by user
Mar 16 16:03:32 localhost sshd[811]: pam_unix(sshd:session): session closed for user pi

daemon.log says similar error what I get from ssh

Mar 16 16:17:01 localhost cron[479]: CRON: gconv_builtin.c:71: __gconv_get_builtin_trans: Assertion `cnt < sizeof (map) / sizeof (map[0])' failed.
Mar 16 17:17:01 localhost cron[479]: CRON: gconv_builtin.c:71: __gconv_get_builtin_trans: Assertion `cnt < sizeof (map) / sizeof (map[0])' failed.
Mar 16 18:17:01 localhost cron[479]: CRON: gconv_builtin.c:71: __gconv_get_builtin_trans: Assertion `cnt < sizeof (map) / sizeof (map[0])' failed.
  • This function is related to encoding and encoding conversions. If you have no odd behavior when logged in directly to RPI corrupt glibc is not likely, but it is possible that some encoding parameter specified by your remote terminal doesn't exist, is incompatible, or malformed. In either case, explore encoding options or try a different remote terminal program – crasic Mar 17 '18 at 17:38
  • Earlier I could connect to this host from same computer – Dániel Kis Mar 17 '18 at 17:40
  • both are from raspberry pi, I have removed the SD card and readed the log from my computer – Dániel Kis Mar 18 '18 at 10:26
  • Please set the loglevel of ssh on your RPi and your computer to verbose, restart sshd on RPi, reconnect from your computer to your RPi and post the correlated logfile sequences and full error messages from your RPi and your computer. – Fabian Mar 18 '18 at 15:26
  • Finally I reinstalled the rasbian, now it works. – Dániel Kis Apr 1 '18 at 20:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.