1

I have freshly installed last Raspbian and updated it. When computer boots up to console, I log in and start command weston-launch. The output of command is something about initializing Raspberry Pi's backend - something like that - but when I want to type something into console it's just frozen and there is not any GUI.

What can I do and how to solve this problem?

  • Has this been solved? If so, please mark the answer that fixed it as such. We're trying to get this site up to par and the Q:A ratio is really bad. Thanks! – RPiAwesomeness Jan 11 '14 at 4:57
2

The build documentation for Wayland on Raspberry Pi indicates that it requires a recent firmware version, and a too old version may cause rpi-backend to malfunction. They suggest using rpi-update to update the firmware.

Also - the final 1.2 version of Wayland/Weston was released around mid-July, and is the version that integrates the RaspberryPi backend, so bugs that may have been in earlier releases could also be causing issues - it may be worth updating and trying again (given that it is now 3-4 weeks since the original question posting).

(Source http://wayland.freedesktop.org/raspberrypi.html and http://lists.freedesktop.org/archives/wayland-devel/2013-July/010278.html)

0

I know this question is quite old, but I couldn't find any helpful answers of today. I ran into the same trouble as the original poster, weston-lauch just freezes after the line "Initializing Raspberry Pi's backend".

I did a firmware upgrade (rpi-update), edited /boot/config.txt as suggested in http://wayland.freedesktop.org/raspberrypi.html, but it still kept freezing for me.

What entirely solved the problem was to run weston-launch with sudo!! No freezing, the GUI started.

Note that I always log in via a different account (not the standard "pi"-user), and maybe some missing permission for my user crash the weston when run without sudo. I still doubt that this is intended behavior...

0

It's hanging because the user you're running weston as doesn't have the necessary permissions.

You need to add whichever user you're running weston-launch as to the groups video and input, and edit a config file.

First add a new udev rule, then add your user to both video and input (run as root. run sudo -i to enter a root console. Press Ctrl+D to exit):

echo 'SUBSYSTEM=="vchiq",GROUP="video",MODE="0660"' > /etc/udev/rules.d/10-vchiq-permissions.rules
usermod -a -G video [your_username]

echo 'SUBSYSTEM=="input", GROUP="input", MODE="0660"' > /etc/udev/rules.d/99-input.rules
echo 'KERNEL=="tty[0-9]*", GROUP="tty", MODE="0660"' >> /etc/udev/rules.d/99-input.rules
usermod -a -G input [your_username]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.