I have this strange problem... When I connect TX and RX pins together (GPIO 14 and GPIO 15, Rev1) and I run minicom, I see everything that I type... so it works.

But when I connect TX RX with an USB FTDI cable to my laptop and run minicom too, I can only receive what it is typed on RPi but not the other way around.

I have connected both Grounds because otherwise it doesnt work at all.

Have I fried my Pi? I was messing with a project which involves 12Volts... I hope didn't damaged it...

  • Have you enabled 'local echo' in minicom? It's ctrl-a then e. I wouldn't worry about the 12V on the UART as RS232 signals are 12V anyway.
    – Kenneth
    Jun 25, 2013 at 18:22
  • local echo works
    – kapcom01
    Jun 25, 2013 at 19:57
  • Sorry if this is obvious but have you remembered to disable diagnostic output on the UART?
    – Kenneth
    Jun 25, 2013 at 21:00
  • yes I had. It turned out to be a minicom problem on the laptop side... I used GtkTerm and I can send and receive now... thanks for your time!
    – kapcom01
    Jun 26, 2013 at 0:05
  • No problem. If you could just create an answer with a description of what you did to solve your problem and mark it as the correct answer you will be helping out others who may have had the same problem.
    – Kenneth
    Jun 26, 2013 at 6:33

4 Answers 4


The GPIO pins are at 3.3V logic level (0 and ~3.3V). You are likely trying to interface to a standard RS-232 device which would require RS-232 voltage levels (positive 3-15V and negative 3-15V).

There are logic level converters out there, but a cheaper solution would be to roll your own with a MAX3232 (3.3V complant MAX232) chip and a small handful of capacitors if you have the skills to put it together.

  • BTW I use a clone of this adafruit.com/products/284#Description
    – kapcom01
    Jun 25, 2013 at 20:00
  • Sorry.... I used GtkTerm and it works... I dont know whats wrong with minicom... I noticed that when I exited minicom it stucked and when I CTRL-Z suddenly everything I typed appeared on RPi's minicom..
    – kapcom01
    Jun 26, 2013 at 0:03

Using GtkTerm on my laptop instead of minicom solved the problem.


May be someone is still facing the same problem.

I was using the Serial to USB converter which works at TTL level. Was trying to interface it with TI microcontroller and faced the same problem. I could receive data but couldn't send from PC to the device. The problem was TTL and RS232 levels mismatch.

Device used RS232 levels only.

Regards, Adil


Try with WiringPi. It worked fine for me. Just install WiringPi and run the SerialTest.c in it. You will be able to get a sequence of values from 0 till 255. Short pin 8 and 10 in RPi and you will be able to see what you send.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.