10

I think there might be a problem with my new Pi. I'm using the same power supply (purchased from PiHut for my previous 3B) in the new 3B+ but I get the rainbow screen and the red power light flashes in a particular pattern: 4 long flashes followed by 4 short flashes. This is very regular, it must be a signal to mean something?

I've tried an alternative PSU and the same problem. I've measured the voltage on both supplies the first being 5.3 V and the second 5.1 V, so well within the requirement. I've tried a couple of different SD cards and the same problem. Anyone have any ideas or seen something similar?

  • 1
    Have you written the latest Raspbian (2018-03-13) image to the SD card you are using? – joan Mar 17 '18 at 16:28
  • this may help ... elinux.org/… ... – jsotola Mar 17 '18 at 17:37
  • Tried latest raspian.. and it booted fine?! How come my existing sd cards I use on the pi 3 don't? is there some setting I need to set somewhere? – Shawson Mar 17 '18 at 20:26
  • the 3b+ needs completely new firmware, so your cards set up for the 3b and older won't work. – scruss Apr 15 '18 at 16:18
15

I've made this answer to summarize the experience to this issue. We are talking about Raspberry Pi 3 Model B+, released on 2018-03-14. It has some new and updated features compared to Raspberry Pi 3 Model B.

  • A 1.4GHz 64-bit quad-core ARM Cortex-A53 CPU
  • Dual-band 802.11ac wireless LAN and Bluetooth 4.2
  • Faster Ethernet (Gigabit Ethernet over USB 2.0), maximum throughput 300 Mbps
  • Power-over-Ethernet support (with separate PoE HAT)
  • Improved PXE network and USB mass-storage booting
  • Improved thermal management

For this we need some additional firmware/drivers.

Raspbian

If you start a new installation then use the latest official software for Raspberry Pi and everything is good.

But you cannot just plug a SD Card from a Raspberry Pi 3 Model B into a Raspberry Pi 3 Model B+ without updating the software. @joan commented [2]:

A simple way to get a consistent new system is to flash a new image (you might have been able to use apt update/upgrade/dist-upgrade as well but that doesn't always work).

Before using a SD Card from an old installation you should first update it. This has the advantage that you do not have to reinstall/reconfigure your installation. Look that you have the raspberry pi archive addressed in your sources.list. It should give you this:

raspberrypi ~$ cat /etc/apt/sources.list.d/raspi.list 
deb http://archive.raspberrypi.org/debian/ stretch main ui
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://archive.raspberrypi.org/debian/ stretch main ui
raspberrypi ~$

Then update your installation:

raspberrypi ~$ sudo apt update
raspberrypi ~$ sudo apt full-upgrade

This is the prefered up to date method. You should now find the file /boot/bcm2710-rpi-3-b-plus.dtb. For most of us this should work. @w00dw0rm has tried 3 things but only flashing a new image helps. I would not advise you to use rpi-update because rpi-update is unstable and may result into an unstable installation, but it's your decision.

I have tested it with a fresh flashed Raspbian Stretch Lite 2017-11-29 in a Raspberry Pi 3 Model B with running wifi. A full-upgrade do:

94 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 147 MB of archives.
After this operation, 290 kB of additional disk space will be used.

It took a long time to do this. When it has finished I do sudo systemctl reboot and the processor stopped to work but doesn't trigger a new start. So I have to pull the power cord after a while (no activity on the green LED anymore). Afterwards the raspi boots fine and everything was working well without any error messages. Powered off the raspi, put its SD Card into a Raspberry Pi 3 Model B+ and it also boots and was working well with running wifi.

Other distributions

The problem here is that they have to update their images with the new firmware and it seems that takes some time. For example Ubuntu does not boot on RPi 3B+ at the time this was written. Some guys here have tried to update their distro with the latest drivers and modules from Raspbian and got it to boot but with limits. One time the wifi does not work [6], the other time keyboard does not function [7]. Look at the date of the image from your distro. If it is older than 2018-03-14 it is most likely that it does not run on a RPi 3B+ [8][9]. I suggest to file a bug report to your distro. The more they get, the earlier they will update.
Update 2018-10-08: Even about 7 month after releasing RPi 3B+ Ubuntu does not support it: Ubuntu Server 18.04 on Raspberry Pi 3 B+: Ethernet Networking Errors on Boot.


references:
[1] https://www.raspberrypi.org/products/raspberry-pi-3-model-b-plus/
[2] Pi 3 Model B+ doesn't boot - Power Supply or broken?
[3] only flashing a new image helps
[4] rpi-update is unstable
[5] Change PI 3 against PI 3 B+
[6] 3B+ fails to boot Ubuntu mate
[7] Run Centos 7 on Pi 3B +
[8] pi-3b+ ubuntu-core boot problem
[9] Comment at Can I run FreeBSD on my Pi?

  • rpi-update is NOT outdated - it continues to do what it is designed to do, i.e. "gets you to the leading edge firmware and kernel". It IS inadvisable to do so without a valid reason, and should NEVER be used just to update the kernel. – Milliways Mar 26 '18 at 23:58
  • @Milliways BUT what is with the answers I have linked to? They are wrong? Quote: "rpi-update will update the firmware to the latest published version, which has to be considered "not stable". So following the recipe given you might end up with an unstable system (has happened to me ;)" – Ingo Mar 27 '18 at 2:01
  • "not stable" DOES NOT mean "outdated"; it may have been widely (mis)used and should be discouraged. – Milliways Mar 27 '18 at 2:47
  • @Milliways OK, I have changed it to unstable. – Ingo Mar 27 '18 at 9:11
4

/boot/bcm2710-rpi-3-b-plus.dtb is missing in older Raspbian images. Just run

sudo rpi-update

on your booted previous Raspberry Pi to fetch the missing firmware. After that you can switch to your new Raspberry Pi 3B+ and boot it with your existing SD card.

  • amazing- i'll give this a go tonight- i thought I'd have to reflash my retropie image and strat over! – Shawson Mar 20 '18 at 11:12
  • This did the trick with the latest version of Jessie, "sudo apt full-upgrade" did not work. – rofavadeka Mar 30 '18 at 11:06
3

I can confirm that the method described by cma works however I was able to use a different method to get a clean install of Raspbian Jessie working without having to load it on a Raspberry Pi 3b first.

Download the Raspberry Pi firmware from https://github.com/raspberrypi/firmware and copy everything in the boot/ directory to the boot partition of the SD card, overwritting the existing files. After booting you can then run rpi-update.

This is probably not the right way to do this but it seemed to work... If someone with more knowledge can explain why this might be a bad idea I would be interested to hear it.

  • > "In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware." – Milliways Mar 27 '18 at 0:00
2

I had a similar problem. Got a brand new Pi 3B+ out o the box and it didn't boot. I only got the rainbow screen, the red led stayed on and the green led continued to blink eight times (4 times long, 4 times short). Downloaded the latest Kali Linux image with no result. Downloaded the latest Raspbian Stretch image (13-3-2018) and the new Pi 3B+ boots without any problem. I think there is something new in the firmware of the latest Raspbian Stretch distribution to accommodate the model 3B+ but that is just guessing from my part.

  • +1 Given the relative timing of your answer compared to the others you were on the mark even though you did not have the details... 8-) – SlySven Dec 28 '18 at 1:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.