2

This question already has an answer here:

In September 2016 I bought a Pi-top with its Pi3B, which I assembled and it runs with the Pi-top software recommended at the time. I recently bought two Pi3B+. Expecting complete computability, I simply swapped the PI3B for a Pi3B+, using the same SD card and same everything else. However, it did not boot. I got the multi-coloured screen the normally briefly occurs, and the red led, but then nothing else. I tried the other Pi3B+ with exactly the same result. Putting the original Pi3B back made everything back to normal. Is there any reason my simple swap should not work? Thanks.

marked as duplicate by goldilocks Apr 7 '18 at 3:38

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3

For the Pi3B+ you need to use the updated Raspbian image dated 2018-03-13.

See https://www.raspberrypi.org/downloads/raspbian/

You can try the following which may work for you. It didn't work for me as I don't use the default repositories.

sudo apt update
sudo apt upgrade
sudo apt dist-upgrade
0

The Raspberry Pi 3B+ uses different network hardware to the previous models, and when the hardware is adressed in the same way as older hardware, the Raspberry Pi throws an error and the boot process fails. A newer system image should solve the problem.

0

As Joan and OneCookieLeft's earlier answers say, it is because you need a newer version of the image (https://www.raspberrypi.org/downloads/)

I didn't find the apt methods helped in my case and in the end opted for a fresh image.

However you may be want to consider this option: afew posts on the Raspberry Pi blog suggested that it might be possible to swap in the new Pi 3B+ if you use rpi-update on your existing card (after backing up your card first!) https://www.raspberrypi.org/blog/raspberry-pi-3-model-bplus-sale-now-35/#comment-1415071

There's a bit more detail on rpi-update here: https://raspberrypi.stackexchange.com/a/4363/82488

Not the answer you're looking for? Browse other questions tagged or ask your own question.