1

I have had a raspberry pi B+ for a little over a year now, and I've noticed consistent performance issues after running motion service for a long period (anything over an hour or so). Originally I was using an older USB camera from a thrift store, then a newer usb camera, and now a picam and it's the same response. I have a hard time ssh'ing or vnc'ing into my pi. Each time, I just delete all of the files created from the motion service in /var/lib/motion and then it works fine.

Has anyone else seen issues with this? Is there another tool/service I can use to record video and stream it over ip?

1

Your SD card is too slow with 5MB/s write speed for this use case. I recommend to get a Class 3 (U3) SD card (or better). Or you could store the files on an external drive (HDD/SSD with USB or NAS).

  • I will try this out. – 1QuickQuestion Mar 19 '18 at 15:25
  • 1
    Thank you for you help! I actually had my sd cards mixed up, and really had an 8GB sandisk Class 1 4MB/s. I ended up upgrading, after some reading about classes, to a 64GB Extreme PLUS sandisk Class3 30MB/s. After the upgrade I've had no issues and it's running pretty smooth. It took a while to test because I was having issues recovering my old setup and actually had to just start from scratch... but thanks again! – 1QuickQuestion Mar 23 '18 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.