6

I've read other related questions here and around other forums but none have helped me so far. I do get the rainbow screen (just a sort of RGB color selector) and some console feedback: enter image description here

That is the last line, after this it just offers the Recovery screen ("For recovery mode hold Shift") and starts again.

I checked and the power adapter is a 5V 2.3A one, I just bought this today and the guy at the store seemed pretty confident in selling this "kit", the SD is a 16GB Samsung one and I do not have another at hand to test. I have it connected via HDMI but no mouse or keyboard at the moment, with or without a mouse/keyboard it still does it. I also tried unplugging the HDMI and connecting it, waited for a minute or so (went to the kitchen) and connected the HDMI, it was rebooting so I believe it is not caused by having the HDMI connected. I also tried installing Raspbian and Archlinux and there was no difference, the output was actually the same, I am using NOOB (love the name btw :] )

Im basically out of ideas, since this is my first day ever owning a Pi Im very fresh in this whole thing...

Any ideas on what could it be?

5

I'm not sure what the problem would be, but I would start with your power supply. Try to trouble-shoot your power supply as this seems like the culprit. You will need some kind of multi-meter or volt-meter to do this test. I would not attach any peripherals including the HDMI cable while conducting the test. Some power supplies do not actually deliver the current they promise.

If the board voltage seems good (5.0 V) while being powered, then I would suspect your SD card and would try to write the latest NOOBS or Raspbian Wheezy image to the card.

  • to add to this: I like to use (Android) phone chargers for the Pi because they seem pretty reliable. I have had problems in the past with using AC to USB power adapters. – John Jun 26 '13 at 2:54
  • Thanks guys!! I do not have a multimeter at hand, but last night I formatted the SD card not in Quick Format as I did last time and after installing it worked fine until I rebooted, so I believe it is not a problem with the power supply and will try with another OS later today, maybe instead of NOOB I'll just go straight to Wheezy. I will make sure to post back here as soon as I have finished testing. – Purefan Jun 26 '13 at 6:53
  • In my case it seems the problem indeed lies in the crappy power supply I got with my kit. After changing the power supply with the old one Raspbian booted without any issues. I'm sick of ebayers selling crappy products and the price wasn't even cheap compared to others! – rbaleksandar Nov 27 '15 at 23:23
3

Ok so I managed to get this fixed by using the Raspbian “wheezy” raw image instead of NOOBS. Here is more precisely what I did:

  1. Format the SD card with SDFormatter, the options I chose were: Format Type: Full (Overwrite) and Format Size Adjustment: On
  2. Downloaded Raspbian Wheezy from here
  3. Extracted the Raspbian Wheeze image and installed it with Win32DiskImager
  4. Put it in the Raspberry Pi and connected the power supply.
  5. The raspi-config program showed up and I enabled to load the GUI/Desktop from there, but I doubt that this is needed, I think at this point it was already working.
  6. Clicked Finish and rebooted. It was working

After that I disabled the GUI by opening a terminal and doing: sudo raspi-config the same interface as before showed up and just disabled it there.

Then I clicked Finish and typed exit to close the terminal, then I mouse clicked the "start" icon and rebooted normally. Perhaps I could have rebooted from the terminal but I didn't want to risk it.

After this it booted to console and it seems to be working just fine now.

1

I had same problem, installed Win10 IOT edition used it for couple hours, the next day I used a different cable (I was using my phone charger before and it was busy at the time) and PI kept rebooting over and over again.

Used a different SD card, same problem.

After reading many posts that point to power supply, I checked the voltage on 5v pin, it was 4.38V.

I was using 5Amp 0-30V adjustable Lab power supply, so I knew it would not be the power supply.

I tried another microUSB cable and Raspberry PI booted without any problem. I measured 4.91V on 5V pins.

Looks like the cables are not created equal, I hope it helps others.

1

I have had a similar problem with re-installing my Pi 3, after adding a 3.5 inch LCD screen. Turns out the wall-wart power supply I was using could not handle the power demands of both.

Check the base requirements for your Pi on this page (about 3/4 of the way down). https://www.raspberrypi.org/help/faqs/ (A Pi 3 requires about 2.5 Amps.)

Then get something a little bigger so you don't overtax the supply.

-2

To me, it is a power adapter issue. It was solved using my Samsung S4 power adapter.

  • You answer in unclear. Is it a power supply issue or an SD Card issue? Second, what evidence are you basing this on? What exactly is the solution? – Steve Robillard Jun 25 '15 at 23:12
  • Also, why would you post an answer when there is already an accepted one? – Purefan Jun 26 '15 at 7:22
  • 1
    @Purefan more answers are (generally) better, and an accepted answer isn't necessarily the best answer, or indeed even the right answer. – Bex Jul 8 '15 at 6:29
  • @Bex I fail to understand how an accepted answer may not be the correct answer, given that it is up to the person who asked the question to mark it as accepted. – Purefan Jul 9 '15 at 7:12
  • 1
    If you look at the accepted answer that was not the issue. You had a separate problem and hence a separate answer. Just because yours was a power issue does not mean the OP's was. So not 100%. – Steve Robillard Nov 10 '15 at 6:08
-2

please be sure that power source has enough currents at least 1 amper

  • 1
    Did you read the question and the OP's own answer? – Steve Robillard Nov 25 '16 at 0:44
  • I had same problem and I thought something wrong with my SD card quality or my raspberry but when I use my 2 Amper ugly power switching instead of my beautiful Apple adapter all endless loop gone – Hamid s k Nov 27 '16 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.