2

I spent really long time googling this, but I didn't find the answer. My main account to using this server is called admin. I'm mounting my hdd (formatted in exfat) via fstab.

UUID=5AAC-E163 /home/admin/films exfat defaults,users,uid=admin,gid=admin 0 0

my start of /etc/init.d/transmission-daemon (I changed only the user part)

NAME=transmission-daemon DAEMON=/usr/bin/$NAME USER=admin STOP_TIMEOUT=30

strange is that can't change chown of /home/admin/films even with root.

sudo chown debian-transmission:debian-trasmission /home/admin/films

It writes to me: Operation not permitted

And finally, my question, why on earth every time when i add torrent it writes to me that permission was denied.

3
  • Please add to your question how you run chown (your complete input) and the error message.
    – Fabian
    Mar 19, 2018 at 20:27
  • chown debian-transmission:debian-trasmission is "debian-trasmission" correct?
    – Fabian
    Mar 20, 2018 at 18:51
  • Can you find some related messages in the journal, e.g. with journalctl -ex? Please give us the output of apt list exfat* and findmnt -t exfat.
    – Ingo
    Mar 20, 2018 at 19:08

2 Answers 2

1

So i finally found out the solution. It is based on a fact that user permissions do not work in exfat. to be clear, you can't change permissions after you mount, so how you mount, it that will remain to the future.


Solution is add umask=0000 in settings when mounting, in my case in fstab.

1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Jan 15, 2020 at 10:58
0

If you mounted your partition as a specific user instead of root, here is a slightly more proper solution to run transmission as the same user you mounted your partition as.

For systemd, here how you should to it:

sudo systemctl edit transmission-daemon.service

Then add:

[Service]
User=your_username

You will also have to copy your transmission config to your user folder:

mkdir -p ~/.config/transmission-daemon/
sudo cp /etc/transmission-daemon/settings.json ~/.config/transmission-daemon/settings.json
sudo chown $USER ~/.config/transmission-daemon/settings.json

Then reload configs and restart transmissions:

sudo systemctl daemon-reload
sudo systemctl restart transmission-daemon

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.