5

Currently I have a PI 3 B running with Raspbian Jessie. It has a 3 TB external Usb-HDD which holds the root partition for the Pi. The SD-Card is only used to start the Grub and afterwards the HDD takes over (which is much faster than running from SD). As the 100 MB ethernet port isn't fast enough, I added an external Usb 1 GB ethernet adapter. Currently the PI does routing and store files.

I then switched to the PI 3 B+, I simply put the SD of the PI 3 B into it and plugged all cables from the previous PI into it. But the PI 3 B+ doesn't seem to boot. The HDD doesn't fire up either. When I remove the SD card and boot again, the PI fires up the HDD but other than that nothing happens.

I also tested the PI 3 B+ with only the SD-Card (the one provided with it, which runs NOOBS), powersupply and connection to an HDMI monitor. It only shows the multicolored startscreen and nothing else, but it shows a flashing lightning symbol.

I have another PI 3 B that boots without problems like the one that I use as a router. I got all PIs from the same vendor.

Is there something special that the PI 3 B+ needs to boot ?

9

Quite simply, extra power. The lightning symbol means the pi isn't getting enough power so try another power source preferably one rated at least 2.5A. The model B+ has slightly more power requirements and it will be especially noticeable if you are also trying to power USB devices like an external HDD.

Also make sure your firmware on the SD card is up to date for the new PI. Run rpi-update and after update, make sure the following file exists before transferring the card:

bcm2710-rpi-3-b-plus.dtb
  • 2
    The HDD isn't powered through the PI (neither PI model is able to provide enough power for this), the HDD has an external power-supply and shouldn't draw power from the PI. And when I tested if the PI 3 B+ model runs with only the power-supply and my TV connected to it, it also shows the lightning symbol (although the PI doesn't have to provide power anywhere in this setup). – Flo S67 Mar 21 '18 at 17:05
  • @FloS67 What's the power rating on your power supply? – Herohtar Mar 21 '18 at 19:32
  • It says 5.1 V with 2.5 A. It is supplied by my vendor with the PI. – Flo S67 Mar 21 '18 at 21:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.