when I tried to tvservice -e "CEA 16", the TV's screen always black-out.

Whether the option is not supported or is it a bug. I am currently, running RASPBIAN NON-NOOBS and running 4.8.16 kernel. Will upgrading to a new kernel can solve this issue.

I tried for long time that I could not able to figure out, my requirement is to set the Screen resolution during runtime( i.e, hotplugging different monitor's or screen)

Any information is of a great help.

  • What make and model of TV are you connecting to ? Are you using hdmi? I would alway suggest using the latest fully updated Raspbian.
    – CoderMike
    Mar 23, 2018 at 10:20

1 Answer 1


Finally, the following resolution solved my issue

The steps are as follows:

- tvservice -p ( the entire goes blank, looks like the TV is OFF ) 
  tvservice -e "CEA 16" or "DMT 39" --> based on the configuration.
- Change the terminal screen from tty7 ( desktop ) to tty1
- Again change the terminal screen from tty1 to tty7.
- The Resolution issue is solved.

The following script helped me:

tvservice -p
sudo chvt 1
sudo chvt 7

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.