0

I recently got a Raspberry Pi 3 Model B+. Apparently this is quite new as of asking this question? On my previous Pi a Raspberry Pi 3 Model B I was running a version of Ubuntu 16.04 LTS 'classic' that I downloaded and flashed onto an SD card with etcher (from this url https://wiki.ubuntu.com/ARM/RaspberryPi) without a problem.

I got the new Pi in the mail stuck that very same SD card in and tried to boot it up and I get stuck on the rainbow screen. It won't boot up. I put the SD card back in the previous model and it boots up just fine.

Some people have mentioned that the firmware is different and needs to be updated? But all of these mentions are referring to Raspbian not Ubuntu.

Is there a way (or need) to update the raspberry pi firmware from Ubuntu?

Any other reason why my Pi might be stuck on this rainbow screen and refusing to boot?

marked as duplicate by Aurora0001, Dmitry Grigoryev, Milliways, Darth Vader Mar 25 '18 at 16:03

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1

I don't use the Server, but Ubuntu MATE has not had a firmware/kernel update for some time (since Wimpy left?). I presume this is also the case for Server.

The Pi3B+ NEEDS new firmware/kernel to boot.

You could try rpi-update (although this needs to be used with caution), OR copy raspberrypi-bootloader raspberrypi-kernel from a Raspbian site (I have not tried this), OR copy the new kernels PLUS their modules from a Raspbian installation.

Not the answer you're looking for? Browse other questions tagged or ask your own question.