9

How can I can use my old Raspbian 8 (Jessie) SD card installation on the Pi 3 B+?

I changed files in /boot. (start.elf, start_cd.elf, start_db.elf, start_x.elf, bcm2708-rpi-0-w.dtb, bcm2708-rpi-b.dtb, bcm2708-rpi-plus.dtb, bcm2708-rpi-cm.dtb, bcm2709-rpi-2-b.dtb, bcm2710-rpi-3-b.dtb, bcm2710-rpi-3-b-plus.dtb, bcm2710-rpi-cm3.dtb, fixup.dat, fixup_cd.dat, fixup_bd.dat, fixup_x.dat) With the files in Raspbian Stretch /boot and the Pi 3 B+ boots but the USB and Ethernet ports do not work.

EDIT -- I have tested rpi-update on Raspberry pi 3. After i put SD card on Raspberry pi 3 B+ the USB works but Ethernet and wifi still not work.

EDIT 2 -- After re-installing Raspbian 8 and made rpi-update on Raspberry pi 3. Ethernet work on Raspberry pi 3 B+ but still wifi not work.

this is dmesg output:

[    4.388752] brcmfmac: F1 signature read @0x18000000=0x15264345
[    4.395773] brcmfmac: brcmf_fw_map_chip_to_name: using brcm/brcmfmac43455-sdio.bin for chip 0x004345(17221) rev 0x000006
[    4.396452] usbcore: registered new interface driver brcmfmac
[    4.411309] brcmfmac mmc1:0001:1: Direct firmware load for brcm/brcmfmac43455-sdio.bin failed with error -2
[    4.931153] systemd-journald[115]: Received request to flush runtime journal from PID 1
[    5.487760] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50
[    6.500044] brcmfmac: brcmf_sdio_htclk: HT Avail timeout (1000000): clkctl 0x50
[    6.502752] uart-pl011 3f201000.serial: no DMA platform data

EDIT 3

I have tested this solution:

wget https://archive.raspberrypi.org/debian/pool/main/f/firmware-nonfree/firmware-brcm80211_20161130-3+rpt3_all.deb
sudo dpkg -i firmware-brcm80211_20161130-3+rpt3_all.deb

It's work.

I succeeded to compile all my projects in Raspbian stretch, I think it was easier than I expected. I suggest also to migrate to Raspbian stretch.

  • Did you also add /boot/bcm2710-rpi-3-b-plus.dtb? That's the relevant firmware for Pi 3 B+ USB and Ethernet. – Ingo Mar 23 '18 at 12:36
  • Yes, this exactly the files that i put it: start.elf, start_cd.elf, start_db.elf, start_x.elf, bcm2708-rpi-0-w.dtb, bcm2708-rpi-b.dtb, bcm2708-rpi-plus.dtb, bcm2708-rpi-cm.dtb, bcm2709-rpi-2-b.dtb, bcm2710-rpi-3-b.dtb, bcm2710-rpi-3-b-plus.dtb, bcm2710-rpi-cm3.dtb, fixup.dat, fixup_cd.dat, fixup_bd.dat, fixup_x.dat, – medismail Mar 23 '18 at 12:51
  • I think, i should change mapping somewhere to use the new firmware ? – medismail Mar 23 '18 at 12:59
  • I've just tried 2017-07-05-raspbian-jessie-lite.img, replaced all filles in /boot with that from 2018-03-13-raspbian-stretch-lite.img. It does not work, simply does not boot on a Pi 3 B+. Seems it isn't suported and you have to change to 2018-03-13-raspbian-stretch-lite.img. Have a look to raspberrypi.stackexchange.com/a/81688/79866 – Ingo Mar 23 '18 at 14:17
  • You need to keep bootcode.bin, cmdline.txt, config.txt, kernel.img and kernel7.img to boot – medismail Mar 23 '18 at 14:52
11

It's really advisable to upgrade to stretch, but if you want/need to stay with Jessie, follow these steps to get it working:

You'll need to do this first step on a pi3 (not plus):

  1. Update the bootloader:

    sudo rpi-update ef7621d91cb58ccc856c3c17ddda28685edd23f3
    

After that the card will then boot on pi 3B+, but without WiFi

  1. Download and install the new WiFi drivers:

    wget https://archive.raspberrypi.org/debian/pool/main/f/firmware-nonfree/firmware-brcm80211_20161130-3+rpt3_all.deb
    sudo dpkg -i firmware-brcm80211_20161130-3+rpt3_all.deb
    

Now you should have a Jessie install that works on 3B+ including WiFi support.

2

The Pi3B+ uses new hardware for networking, and thus needs new drivers (among other things - including a kernel which supports them and DeviceTree).

It MAY be possible to update Jessie with the necessary files; rpi_update MAY do this, although this has attendant risks.

Jessie will soon be unsupported anyway, so you would be better to update to Stretch.

0

Have you tried the following?

WiFi is disabled until wireless regulatory domain is set (Pi 3 B+ only) - The domain can be done through 'Raspberry Pi Configuration' (rc_gui), 'raspi-config' or by setting 'country=' to an appropriate ISO 3166 alpha2 country code in /etc/wpa_supplicant/wpa_supplicant.conf.

  • Yes, I already set country code. But no wlan detected, as you can see in dmesg it doesn't recognize wlan at all. – medismail Apr 3 '18 at 14:27
0

For those arriving here that have the OS installed with NOOBS and want to avoid a headache like I had, you need to know that you also need to update NOOBS files in order for the card to boot on the PI 3 B+ (else you are stuck in the rainbow-like boot screen).

Just plug the SD card in the PC through a card reader, download NOOBS LITE, unzip and overwrite all the files on the recovery partition, EXCEPT recovery.cmdline (in the downloaded NOOBS it contains the silentinstall option which formats the SD and prepares it for a fresh installation on first boot).

protected by Ghanima Jul 14 '18 at 23:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.