3

I get this error when I run 'raspistill -t 2000 -o image.png -e png '

mmal: Cannot read cameara info, keeping the defaults for OV5647 mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM) mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1) mmal: Failed to create camera component mmal: main: Failed to create camera component

mmal: Camera is not detected. Please check carefully the camera module is installed correctly

  • Camera option is enabled and had tried updating/upgrading the firmware – UnbreakableMystic Mar 24 '18 at 0:26
  • Recheck the cable connections? Also, be sure to run sudo apt-get update && sudo apt-get upgrade to make sure you are running with the latest software. – SDsolar Apr 7 '18 at 7:39
  • I had the same problem. I ran everything that was said above. It finally worked after I checked the connection between the camera an the board. – Pranav Sep 2 at 11:46
4

I would double check that the camera is correctly connected at both ends and not loose, and that it is enabled via the RPI config menu. The RPi+ camera draws about 260 mA more current than the board so you need a large enough power supply to support the added load.

After the camera is enabled, you also need a reboot. Check that /boot/config.txt contains the lines:

start_x=1
gpu_mem=128

This will confirm if the camera is properly enabled. If the GPU memory is too small the camera will not work. Also try running a sudo rpi-update.

There are two ways of accessing the camera: Through the Broadcom specific MMAL library, which is used by raspistill and raspivid, or via Video4Linux2, which is a cross platform standard. If you have V4L2 installed then you can try to access the camera through that driver to see what happens. V4L2 should come pre-installed on the latest Raspberian OS. You can check by typing which v4l2-ctl. Normally it is /usr/bin/v4l2-ctl, otherwise try a sudo apt-get install v4l-utils.

To enable it to access the camera, you should first load the driver module by typing

sudo modprobe bcm2835-v4l2.

This should create a camera device at /dev/video0. You can then get information by typing

v4l2-ctl --all.

This will list a huge amount of information about any cameras in the system and their settings and drivers. And by typing

v4l2-ctl --device=/dev/video0 --list-formats-ex

you can determine the list of frame sizes and frame rates supported.

There's also the possibility that you have a faulty camera board.

| improve this answer | |
0

Maybe the camera is disabled eg. using a new image. To enable the camera run:

sudo raspi-config

At the blue screen, select interface point and enable camera.

And finally reboot the raspberry.

sudo reboot now
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.