0

I am trying to set up an access point on my RPI V3 running Raspian stretch. It has been running this configuraton before but then my SD-Card failed.. I am wondering though if it was really the same OS version I was running because the old configuration does not seem to work any more. Main differences - I could not configure anything in /etc/network/interfaces. If I try to set up the static interface I want to run the hotspot on in /etc/network/interfaces dhcpcd fails and no interfaces are configured at all. So now the interface is defined in /etc/dhcpcd.conf, /etc/hostapd/hostapd.conf looks like this:

# Basic configuration

country_code=NZ

# This is the name of the WiFi interface we configured above
interface=wifi0

# Use the nl80211 driver with the brcmfmac driver
# driver=nl80211

# This is the name of the network
ssid=QIFI

# Use the 2.4GHz band
hw_mode=g

# Use channel 6
channel=6

# Enable 802.11n
ieee80211n=1

# Enable WMM
wmm_enabled=1

# Enable 40MHz channels with 20ns guard interval
ht_capab=[HT40][SHORT-GI-20]
#[DSSS_CCK-40]

# Accept all MAC addresses
macaddr_acl=0

# Use WPA authentication
auth_algs=1

# Require clients to know the network name
ignore_broadcast_ssid=0

# Use WPA2
wpa=2

# Use a pre-shared key
wpa_key_mgmt=WPA-PSK

# The network passphrase
wpa_passphrase=secret123

# Use AES, instead of TKIP
rsn_pairwise=CCMP

When I run sudo hostapd /etc/hostapd/hostapd.conf I get the following output:

Configuration file: /etc/hostapd/hostapd.conf
Failed to create interface mon.wifi0: -95 (Operation not supported)
wifi0: interface state UNINITIALIZED->COUNTRY_UPDATE
wifi0: Could not connect to kernel driver
Using interface wifi0 with hwaddr b8:27:eb:2b:34:88 and ssid "QIFI"
random: Cannot read from /dev/random: Resource temporarily unavailable
random: Only 0/20 bytes of strong random data available from /dev/random
random: Not enough entropy pool available for secure operations
WPA: Not enough entropy in random pool for secure operations - update keys later when the first station connects
wifi0: interface state COUNTRY_UPDATE->ENABLED
wifi0: AP-ENABLED 
random: Cannot read from /dev/random: Resource temporarily unavailable

Unfortunately the WIFI does not show up. The error above - could not connect to kernel driver does not sound good.. What can I do to get this up & running ?

2
  • I had to disable dhcpcd, it kept messing up my configuration too. – Gerard H. Pille Mar 24 '18 at 21:31
  • Very true. The problem is gone since I managed to set up my network using /etc/network/interfaces alone and disabling dhcpcd alltogether. dhcpcd seems to mess around with wpa_supplicant on the interface allthough it is statically configured. I could see on my wifi router that the interface I had set up for hostapd still showed up as connected. So I guess hostapd & wpa_supplicant mess up each others configuration.. – Thomas Mar 24 '18 at 22:32
0

Use /etc/network/interfaces for wlan config and disable dhcpcd. Hostapd working on Pi Zero W on stretch-lite and buster-lite! Many posts talk about driver issues and most recent posts leave /etc/network/interfaces unchanged. Comments in this post have it right. Thank you!!

1
  • It doesn't make any difference with the driver if using /etc/network/interfaces. It is exactly the same driver and firmware used. – Ingo Oct 1 '20 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.