1

I want to run Windows 10 IoT Core for Raspberry Pi on virtual machine to check how it works before I will buy my first Raspberry Pi.

To start I used this tutorial: https://github.com/agaboduarte/Install-Windows-IoT-On-HyperV

So I created Virtual Hard Drive, then via dism i copied files to that virtual hard drive. Next i created virtual machine with previously created hard drive using Hyper-V.

When I start and connect to Virtual machine i see only black screen with blinking cursor in third line... (I waited for 30 min or longer...)

Do you have similar problems? How to fix this?

I tried with Windows 10 IoT from this site: https://developer.microsoft.com/en-us/windows/iot/Downloads and also with insider preview and result is the same.

Update: I downloaded Windows IoT for MinnowBoard MAX and I'm able to run it on hyper-v. So why there is problem wth version for raspberry pi?

  • 1
    First thought is that the MinnowBoard is Intel-based; it would be easily emulated on your (Intel-based) Windows machine. While the Raspberry Pi is ARM-based. It is a different CPU architecture. I've never tried to emulate the Raspberry Pi using Hyper-V. I have successfully used QEMU to emulate the Pi on my Windows machine. – wasatchwizard Mar 25 '18 at 17:47
  • 1
    As previous comment states, you need to EMULATE the Rpi because it's a different architecture - Hyper-V does not Emulate other CPU's, it is a virtualiser for the current CPU – Jaromanda X Mar 25 '18 at 23:05
  • What exactly do you want to verify by running that IoT core on a VM? – Dmitry Grigoryev Mar 26 '18 at 10:57
  • Yea.. I tried to do this so I could compile things quicker on the "Pi" but that led me down cross chain compiling or something. I kind of got it working using QT Emulator but its so bloody slow (likeJan 2017) and it was pointless. One way to try it is just install the image onto your machine on another partition or temporary drive. Rasbpian is built on Debian.. which runs on x86/64 ... – Piotr Kula May 2 '18 at 7:19
0

If you have an old laptop you can use that and install it there. Just to try it out on your machine you can boot from the USB drive. BIOS must be able to boot from USB

!ACTHUNG!WARNING!

Make sure you select the correct drives during the entire installation process. Namely Partitioning and GRUB sections. It may cause irreversible data loss!

Lets Start

  • Download the Raspbian ISO (Full Image not Net installer)
  • Download Rufus, a tool to help you burn ISO to USB
  • Get your USB Mass storage device (minimum 2GB), insert it and run Rufus
  • 3/4 way down the screen click on the CD-ROM icon to select the ISO
  • Click start

That process will burn the ISO the USB Mass Storage. Once complete you can then reboot your machine and boot from USB

  • An installer screen will show up. Select "Graphical Install"
  • Select your language and other settings
  • Use "GUIDED - Use entire disk"
  • Partition Disk - Select the single entry (make sure the size that its your USB!!)
  • It will start installing.. wait a while.. I recommend making some Turkish chai or Vietnamese coffee drip
  • You will get to a screen asking about "Install GRUB ..." ? - Select Yes
  • Select your USB stick again
  • Afterwards it will reboot - Boot from USB again

Et Viola, you has Raspbian OS running on your machine, albeit in x86 mode and not in ARM

So keep in mind anything specific to ARM will not work, like compiling ARM sources will not work! Use apt-get to install packages or if downloading packages use the x86 compiled ones

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.