0

SO I have to run a custom electron app which is running on AMD device after installing node.js from this site,

https://ourcodeworld.com/articles/read/410/how-to-install-node-js-in-kali-linux

Is there a way I can get this entire thing for Kali running on a Raspberry Pi. I have tried changing the node.js file to that of an ARM device but then it doesn't run the next step "./configure" after that and also just stops tar process in between showing error " too many arguments ". Please suggest a way to get this exact setup on Raspberry Pi.

  • Are you trying to build nodejs for raspberry pi? – Jaromanda X Mar 26 '18 at 8:49
  • @JaromandaX I have software i got from someone which works on linux kali on AMD devices and i want to run it on kali running on raspberry Pi. When I install nodejs and do a electron-rebuild gives a long list of error and when i run the software just shows the window without anything inside it – Ankit Sharma Mar 27 '18 at 2:57
  • Oh, ok, didn't really understand what was happening in the link - that seems to be how to install node.js - which seems extremely complicated compared to how I do it - re-reading it again, that link seems to be "how to build nodejs" ... nothing about "electron" at all – Jaromanda X Mar 27 '18 at 3:02
  • To be honest, I find it unlikely that you get tar errors when running the ./configure step - seeing as ./configure does nothing with tar as far as I can see - I think you need to check you've typed tar xzvf node-latest.tar.gz && cd node-v* correctly - i.e. can you see a folder called node-v9.9.0 ? – Jaromanda X Mar 27 '18 at 3:19
  • @JaromandaX I am done with the nodejs installation now I guess but the app shows just a blank screen. Now I think maybe it is because it was a x86 native application and I am trying to make it run on ARM. Although it still loads the app but just a blank screen – Ankit Sharma Mar 27 '18 at 3:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.