0

When I want to install a package or do an apt-get update, the system returns an error like (read-only file system) can you help me please. I have Raspbian Stretch Lite.

I did not download other packages because I can not install anything on the system.

Command: sudo apt-get update

Error messages are like: Err 3: mirrordirector.rasbian.org/debian streatch Release open (30: Read-only file system) Could not create temporary file to work with

  • You should also edit to clarify whether this is this a new installation; have you been able to install packages previously? Might the SD card be write-locked? – Aurora0001 Mar 27 '18 at 19:28
  • command: sudo apt-get update error messages are like: Err 3: mirrordirector.rasbian.org/debian streatch Release open (30: Read-only file system) Could not create temporary file to work with ... – Mohamed El Guendouz Mar 27 '18 at 19:45
  • It sounds like you have a corrupted file system. Flash the SD card again. If it still fails get another SD card. – joan Mar 27 '18 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.