I tried with restart "sudo shutdown -r 0", but I got an error: "Failed to connect to bus:no such file or directory"

What does this mean? I worked on headless Raspberry on some server configuration and I'm not sure what is wrong. I suspect "Anything Sync Daemon" where I add and remove some folder. But now daemon is stopped, so this shouldn't be a problem. Any idea?

  • This seems not to be specific for raspberry pi. What says google? – Ingo Mar 28 '18 at 11:19
  • It seems a general systemd problem. Some have reported that sudo su - followed by the shutdown or actually logging in as root solves the problem, but others have resorted to removing the power. – Ljm Dullaart Mar 28 '18 at 11:34
  • I searched but didn't find a similar problem. I tried many different things, but nothing helps. Full restore will follow. – JanezKranjski Mar 28 '18 at 15:59

I saw something similar while resetting the password. In that case I was in single user mode. From there, closing the window (Control-D) caused the system to shut down.

| improve this answer | |
  • What is "single user mode"? – Mohammad Ali Sep 30 '18 at 1:24
  • As described in this article: mapledyne.com/ideas/2015/8/4/… you can configure Rasbian to boot into a single user mode. In that mode you will not be able to use shutdown. – trindflo Oct 8 '18 at 19:23

Raspbian comes with the systemd init system since version Jessie. I assume your system has this also running. systemd heavily uses dbus for interprocess communication and it seems that it is missing. Try to install it and reboot:

rpi ~$ sudo apt install dbus
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.