I am working on a project using a RPi3 (OS: stretch) and a 3G dongle (usb stick). After 36 hours ish... my USB disconnects and I need to manually execute the "usb_modeswitch" command. As the pi should work remotely, I would like to know how to avoid this... In my syslog I have the following result:

dhcpcd: eth0: removing interface

and then all my usb ports got disconnected...

Do you know how to avoid this?

Your help would be very appreciated.


  • I wouldn't mind. Pity we seem to have lost the OP. Commented Mar 28, 2018 at 23:07

1 Answer 1


Disable dhcpcd (remove it), and configure your network manually. A little effort and your system will run for months without trouble.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.