Recently I got Nano USB to Bluetooth Dongle v2.0.

I tried to install it by following the instructions but culdn't figure out why the module is not visible.

I ran the following procedure:

sudo apt-get update
sudo apt-get upgrade
yudo apt-get install bluetooth bluez-utils blueman

but when running lsusb, the device is not visible. Does anyone know what could be wrong or how to fix the issue?

  • did you have any chance in resolving your issue? if yes, could you close this question? (by accepting an answer, or adding one, or editing or removing your question)
    – ySiggen
    Commented Jun 19, 2014 at 21:46

2 Answers 2


First check if usb device is recognized at all. After pluging it in check run

sudo dmesg

If is not correctly recognized it can be hardware fault or, as it is common with raspberry, not enough power supplied from raspberry. Check it again with powered hub or Linux PC/laptop.


I just had some hardtime with a 4.0 dongle myself. The lsusb command wouldn't show my device either despite updating everything. It was strange as dmesg would show it. I ended up taking a new one! Try out another dongle!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.