3

I've just acquired a "Huawei E8372" USB dongle. I'm trying to connect to Tesltra (Australia). I switched off the wifi function of the dongle. I've managed to get the dongle recognised as /dev/USB1 using usb_modeswitch. I'm using raspbian stretch. I've created the following scripts:

/etc/ppp/peers/telstra:

connect "/usr/sbin/chat -v -f /etc/ppp/telstra"
/dev/ttyUSB1
115200
noipdefault
usepeerdns
defaultroute
replacedefaultroute
persist
noauth
debug

/etc/ppp/telstra:

ABORT 'NO CARRIER'
ABORT 'NO DIALTONE'
ABORT 'BUSY'
ABORT 'ERROR'
ABORT 'NO ANSWER'
'' 'ATZ'
OK 'AT&F'
OK 'ATQ0 V1 E1'
OK 'AT&D2 &C1'
OK 'AT+FCLASS=0'
OK 'ATS0=0'
OK 'AT+CGDCONT=1,"IP","telstra.internet"'
OK 'ATDT*99#'
CONNECT ''

I get the following in my syslog when I enter 'pppd call telstra':

Mar 31 16:32:22 raspberrypi chat[1273]: abort on (NO CARRIER)
Mar 31 16:32:22 raspberrypi chat[1273]: abort on (NO DIALTONE)
Mar 31 16:32:22 raspberrypi chat[1273]: abort on (BUSY)
Mar 31 16:32:22 raspberrypi chat[1273]: abort on (ERROR)
Mar 31 16:32:22 raspberrypi chat[1273]: abort on (NO ANSWER)
Mar 31 16:32:22 raspberrypi chat[1273]: send (ATZ^M)
Mar 31 16:32:22 raspberrypi chat[1273]: expect (OK)
Mar 31 16:32:23 raspberrypi chat[1273]: 33^@^@^@^V
Mar 31 16:32:23 raspberrypi chat[1273]: [^O'^Zd^F]`^@^@^@^@$^@^A~^@^@^@^@^@^@^@^H[^O^?~'^Zd^?^B^@^@^@^@^@^@^@^@^@^@^@^@^@^V:^@^E^B^@^@^A^@^O^@@"^@^@^@^A^D^@^@^@^?^B^@^@^@^@^@^@^@^@^@^A^?
Mar 31 16:32:33 raspberrypi chat[1273]: ^@^@^@33^@^@^@^AT%j^VjU^F]`^@^@^@^@ :^?~^@^@^@^@^@^@^@V%j^?~^VjU^?^B^@^@^@^@^@^@^@^@^@^@^@^@^@^A^F^@Uv@H^G^H^@^@^@^@^@^@^@^@^E^A^@^@^@^@^E
Mar 31 16:32:49 raspberrypi chat[1273]: 4^A^AT%j^VjU33^@^@^@^AT%j^VjU^F]`^@^@^@^@ :^?~^@^@^@^@^@^@^@V%j^?~^VjU^?^B^@^@^@^@^@^@^@^@^@^@^@^@^@^A^F^@Uv@H^G^H^@^@^@^@^@^@^@^@^E
Mar 31 16:33:07 raspberrypi chat[1273]: alarm
Mar 31 16:33:07 raspberrypi chat[1273]: Failed
Mar 31 16:33:07 raspberrypi pppd[1194]: Script /usr/sbin/chat -v -f /etc/ppp/telstra finished (pid 1272), status = 0x3
Mar 31 16:33:07 raspberrypi pppd[1194]: Connect script failed
Mar 31 16:33:08 raspberrypi pppd[1194]: Exit.
3

Thanks for reformatting my post. I don't quite know how you did it, but I'll try next time!

This device does not use ppp or a chat script. It creates a virtual network device.

I found the answer here: https://www.raspberrypi.org/forums/viewtopic.php?t=159344

I put

max_usb_current=1

in /boot/config.txt, and

ACTION=="add", SUBSYSTEM=="usb", ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1f01", RUN+="/usr/sbin/usb_modeswitch -v 0x12d1 -p 0x1f01 -V 0x12d1 -P 0x1405 -J"

in /etc/udev/rules.d/70-usb-modeswitch.rules.

Apologies if formatting not right!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.