-1

We have an RPi3, but we are not able to connect to the wifi network. It shows "No wireless interfaces found". We have tried modifying 'wpa_supplicant.conf' file but it didnt help. Also we tried ipconfig, it doesn't show the RPi's ip address. Any suggestions?

  • 2.4 or 5 GHz wifi? RPi 3 model B+? – Fabian Mar 31 '18 at 9:50
  • Try connecting a USB dongle and/or Ethernet cable. Do you still get the problem? – dominic03 Feb 24 at 4:32
0

I do not know what command produces the message but there are a number of things to check:

lsusb -t will give you a tree of usb-devices. The standard wlan0 sould be a device with Driver=r8712u. If there is no such device, you may try modprobe r8712u. If that doesn't work, your wifi on the pi may be broken.

grep dhcpcd /var/log/daemon.log

This should give a number of messages, for example:

wlan0: carrier acquired
wlan0: IAID f6:de:30:ad
wlan0: adding address fe80::20c:f6ff:fede:30ff

etetera.

iwlist wlan0 scan should give you a number of access points that the pi sees. Check if the pi can see your access-point.

iwconfig wlan0 will show whether the pi is connected to an access-point. if it is not: check the wpa_supplicant.conf; it may have an error.

ifconfig wlan0 will show whether you have an IP address on the wlan0 interface, but you already tried that. But if all the rest works, you should put a fixed IP address on the pi in /etc/dhcpcd.conf:

interface wlan0
static ip_address=192.168.178.4/24
static routers=192.168.178.1
static domain_name_servers=192.168.178.6

(adjust to your network). This will work if dhcp on your wifi is broken.

oh, some commands require root-access; you may need to sudo them.

0

Here is how I solved it ( for rasbian stretch ) after reading hundreds of posts:

https://www.raspberrypi.org/documentation/configuration/wireless/wireless-cli.md

Typed: sudo raspi-config Typed in ssid and password

Solved

Cheers, Brad

0

It seems like the wifi_suppicant service is down. This happened to me 15 days ago while I was updating software. After flashing the latest buster release the problem was gone. So flash the sdcard and you will find it corrected. Backup anything important before doing so.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.