1

I have tried to install docker on the latest rasbian:

Uname -a
Linux mypi 4.9.80-v7+ #1098 SMP Fri Mar 9 19:11:42 GMT 2018 armv7l GNU/Linux

but I get the following error:

sudo apt-get install docker-ce
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  aufs-dkms aufs-tools cgroupfs-mount cpp-4.6 dkms gcc-4.6 libltdl7 linux-headers-3.6-trunk-common linux-headers-3.6-trunk-rpi linux-kbuild-3.6
  linux-kbuild-4.9 pigz
Suggested packages:
  aufs-dev gcc-4.6-locales python3-apport menu libmudflap0-4.6-dev gcc-4.6-doc libgcc1-dbg libgomp1-dbg libquadmath-dbg libmudflap0-dbg
  libcloog-ppl1 | libcloog-ppl0 libppl-c4 libppl12 | libppl9 binutils-gold
The following NEW packages will be installed:
  aufs-dkms aufs-tools cgroupfs-mount cpp-4.6 dkms docker-ce gcc-4.6 libltdl7 linux-headers-3.6-trunk-common linux-headers-3.6-trunk-rpi
  linux-kbuild-3.6 linux-kbuild-4.9 pigz
0 upgraded, 13 newly installed, 0 to remove and 0 not upgraded.
Need to get 14,3 MB/38,4 MB of archives.
After this operation, 169 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.tugraz.at/mirror/raspbian/raspbian stretch/main armhf pigz armhf 2.3.4-1 [50,0 kB]
Get:2 http://ftp.tugraz.at/mirror/raspbian/raspbian stretch/main armhf dkms all 2.3-2 [74,8 kB]
Get:3 http://ftp.tugraz.at/mirror/raspbian/raspbian stretch/main armhf linux-kbuild-4.9 armhf 4.9.51-1+rpi3 [671 kB]
Get:4 http://ftp.tugraz.at/mirror/raspbian/raspbian stretch/main armhf aufs-dkms armhf 4.9+20161219-1 [169 kB]
Get:5 http://ftp.tugraz.at/mirror/raspbian/raspbian stretch/main armhf aufs-tools armhf 1:4.1+20161219-1 [101 kB]                                    
Get:6 http://ftp.tugraz.at/mirror/raspbian/raspbian stretch/main armhf cgroupfs-mount all 1.3 [5.716 B]                                              
Get:7 http://ftp.tugraz.at/mirror/raspbian/raspbian stretch/main armhf cpp-4.6 armhf 4.6.4-5+rpi1 [4.145 kB]                                         
Get:8 http://ftp.tugraz.at/mirror/raspbian/raspbian stretch/main armhf gcc-4.6 armhf 4.6.4-5+rpi1 [4.363 kB]                                         
Get:9 http://ftp.tugraz.at/mirror/raspbian/raspbian stretch/main armhf linux-headers-3.6-trunk-common armhf 3.6.9-1~experimental.1+rpi7 [4.189 kB]   
Get:10 http://ftp.tugraz.at/mirror/raspbian/raspbian stretch/main armhf linux-kbuild-3.6 armhf 3.6-1~experimental.1+rpi2+b2 [136 kB]                 
Get:11 http://ftp.tugraz.at/mirror/raspbian/raspbian stretch/main armhf linux-headers-3.6-trunk-rpi armhf 3.6.9-1~experimental.1+rpi7 [414 kB]       
Fetched 14,3 MB in 45s (316 kB/s)                                                                                                                    
Selecting previously unselected package pigz.
(Reading database ... 37325 files and directories currently installed.)
Preparing to unpack .../00-pigz_2.3.4-1_armhf.deb ...
Unpacking pigz (2.3.4-1) ...
Selecting previously unselected package dkms.
Preparing to unpack .../01-dkms_2.3-2_all.deb ...
Unpacking dkms (2.3-2) ...
Selecting previously unselected package linux-kbuild-4.9.
Preparing to unpack .../02-linux-kbuild-4.9_4.9.51-1+rpi3_armhf.deb ...
Unpacking linux-kbuild-4.9 (4.9.51-1+rpi3) ...
Selecting previously unselected package aufs-dkms.
Preparing to unpack .../03-aufs-dkms_4.9+20161219-1_armhf.deb ...
Unpacking aufs-dkms (4.9+20161219-1) ...
Selecting previously unselected package aufs-tools.
Preparing to unpack .../04-aufs-tools_1%3a4.1+20161219-1_armhf.deb ...
Unpacking aufs-tools (1:4.1+20161219-1) ...
Selecting previously unselected package cgroupfs-mount.
Preparing to unpack .../05-cgroupfs-mount_1.3_all.deb ...
Unpacking cgroupfs-mount (1.3) ...
Selecting previously unselected package cpp-4.6.
Preparing to unpack .../06-cpp-4.6_4.6.4-5+rpi1_armhf.deb ...
Unpacking cpp-4.6 (4.6.4-5+rpi1) ...
Selecting previously unselected package libltdl7:armhf.
Preparing to unpack .../07-libltdl7_2.4.6-2_armhf.deb ...
Unpacking libltdl7:armhf (2.4.6-2) ...
Selecting previously unselected package docker-ce.
Preparing to unpack .../08-docker-ce_18.03.0~ce-0~raspbian_armhf.deb ...
Unpacking docker-ce (18.03.0~ce-0~raspbian) ...
Selecting previously unselected package gcc-4.6.
Preparing to unpack .../09-gcc-4.6_4.6.4-5+rpi1_armhf.deb ...
Unpacking gcc-4.6 (4.6.4-5+rpi1) ...
Selecting previously unselected package linux-headers-3.6-trunk-common.
Preparing to unpack .../10-linux-headers-3.6-trunk-common_3.6.9-1~experimental.1+rpi7_armhf.deb ...
Unpacking linux-headers-3.6-trunk-common (3.6.9-1~experimental.1+rpi7) ...
Selecting previously unselected package linux-kbuild-3.6.
Preparing to unpack .../11-linux-kbuild-3.6_3.6-1~experimental.1+rpi2+b2_armhf.deb ...
Unpacking linux-kbuild-3.6 (3.6-1~experimental.1+rpi2+b2) ...
Selecting previously unselected package linux-headers-3.6-trunk-rpi.
Preparing to unpack .../12-linux-headers-3.6-trunk-rpi_3.6.9-1~experimental.1+rpi7_armhf.deb ...
Unpacking linux-headers-3.6-trunk-rpi (3.6.9-1~experimental.1+rpi7) ...
Setting up aufs-tools (1:4.1+20161219-1) ...
Setting up cpp-4.6 (4.6.4-5+rpi1) ...
Setting up linux-headers-3.6-trunk-common (3.6.9-1~experimental.1+rpi7) ...
Setting up cgroupfs-mount (1.3) ...
Setting up dkms (2.3-2) ...
Setting up linux-kbuild-4.9 (4.9.51-1+rpi3) ...
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Processing triggers for systemd (232-25+deb9u2) ...
Setting up libltdl7:armhf (2.4.6-2) ...
Setting up gcc-4.6 (4.6.4-5+rpi1) ...
Processing triggers for man-db (2.7.6.1-2) ...
Setting up linux-kbuild-3.6 (3.6-1~experimental.1+rpi2+b2) ...
Setting up pigz (2.3.4-1) ...
Setting up docker-ce (18.03.0~ce-0~raspbian) ...
Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xe" for details.
invoke-rc.d: initscript docker, action "start" failed.
● docker.service - Docker Application Container Engine
   Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
   Active: activating (auto-restart) (Result: exit-code) since Sun 2018-04-01 11:12:27 CEST; 37ms ago
     Docs: https://docs.docker.com
  Process: 21340 ExecStart=/usr/bin/dockerd -H fd:// (code=exited, status=1/FAILURE)
 Main PID: 21340 (code=exited, status=1/FAILURE)
      CPU: 562ms

ápr 01 11:12:27 mypi systemd[1]: docker.service: Unit entered failed state.
ápr 01 11:12:27 mypi systemd[1]: docker.service: Failed with result 'exit-code'.
dpkg: error processing package docker-ce (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up aufs-dkms (4.9+20161219-1) ...
Loading new aufs-4.9+20161219 DKMS files...
It is likely that 4.9.80-v7+ belongs to a chroot's host
Building for 3.6-trunk-rpi, 4.14.30+ and 4.14.30-v7+
Building initial module for 3.6-trunk-rpi
Error!  The dkms.conf for this module includes a BUILD_EXCLUSIVE directive which
does not match this kernel/arch.  This indicates that it should not be built.
Skipped.
Module build for kernel 4.14.30+ was skipped since the
kernel headers for this kernel does not seem to be installed.
Module build for kernel 4.14.30-v7+ was skipped since the
kernel headers for this kernel does not seem to be installed.
Setting up linux-headers-3.6-trunk-rpi (3.6.9-1~experimental.1+rpi7) ...
Examining /etc/kernel/header_postinst.d.
run-parts: executing /etc/kernel/header_postinst.d/dkms 3.6-trunk-rpi
Error!  The dkms.conf for this module includes a BUILD_EXCLUSIVE directive which
does not match this kernel/arch.  This indicates that it should not be built.
Processing triggers for libc-bin (2.24-11+deb9u3) ...
Errors were encountered while processing:
 docker-ce
E: Sub-process /usr/bin/dpkg returned an error code (1)

How can I install docker on this rasbian?

Do I need to downgrade?

0

I also experienced this error on my rpi3 with stretch installed. I downgraded to jessie, and followed the tutorial here: https://docs.docker.com/install/linux/docker-ce/debian/#upgrade-docker-ce-1 using the convenience script, and everything worked fine.

I am not sure what might have caused it fail on stretch, i read somewhere else that it was due to missing headers or smth like that, im not sure.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.