0

I have formatted my card and written the latest version of Pi Zero from the RetroPie website. Brand new microSD card, card reader, and HDMI wires. The tv screen stays blank when I plug the Pi0 in. I tried reformatting a few times. Unplugging/plugging in.

I'm really new to all this and I wasn't sure how long to wait before anything displayed upon initial boot? Or if I missed a crucial step? I don't think so, but I guess I don't know what I'm looking at. Thank you for your help. I am sure I formatted properly, then used win32 to write to the SD card. Then place it into the Pi, connect USB, HDMI, and power. But nothing. I've waited as long as 10 minutes, but still blank screen. :(

  • There is a green LED labelled ACT in the corner near the camera connector on the opposite side from the GPIO breakout. What does it do when you plug in? – goldilocks Apr 1 '18 at 15:04
  • Thank you. It lightly flickers (not definite flashes), but then stabilizes within a few seconds. Even now, it's steady on. I'm using a power source recommended by everyone I've studied from in these boards. 2.0 or greater. I tried to connect to a smaller HDTV, but it reads: "Not Supported" in the corner. But the main tv is a bigger one and it's just blank. – Steve J Apr 1 '18 at 15:17
  • All I did was write the RetroPie 0/1 card image to the SDcard... Is that sufficient? I followed the directions at the RetroPie "First Installation" video to a T. :) – Steve J Apr 1 '18 at 15:19
0

[the ACT LED] lightly flickers (not definite flashes), but then stabilizes within a few seconds. Even now, it's steady on.

The flickering is good, this indicates activity on the SD card. The norm on a Pi Zero is for it to flicker irregularly for < 1 min and then remain on. However, before that point you should see stuff on the screen.

You should try setting hdmi_safe=1 or hdmi_force_hotplug=1 in config.txt on the first partition -- unless you are using a linux machine, you will probably see only that one. If you can't find any partitions on the card, remake it.

If the green led is off, this is what will happen with no SD card in (i.e., it is being rejected right away, usually this is misformatting).1 Possibly it was doing the normal thing at one point and then got corrupted when you pulled the power, so you may have to recreate the card and set that option in config.txt.


1. Beware, as per scitronboy's comment below, that the ACT led on the Pi Zero behaves inversely to that on other models.

  • @ SteveJ , goldilocks, THAT IS NOT TRUE ON RPI ZERO. On the rpi zero and zero w, the power light and ACT led are the same, so the ACT signals are inverted(the led is normally on, and it flickers off when the sd card is being accessed.) That way, you know when your rpi is on and when the sd card is being accessed, with the same led. – scitronboy Apr 1 '18 at 16:04
  • @scitronboy Thanks much! I had a nagging feeling about that but was too lazy to plug one in and check (and unfortunately searching 'pi zero act led' did not produce anything definitive, so I assumed I was misremembering). – goldilocks Apr 1 '18 at 17:19
  • Thank you so much, goldilocks and scitronboy!! I edited the config file and it worked beautifully! Whew! Man, what a save!! I am very happy tonight! – Steve J Apr 1 '18 at 22:10
  • @goldilocks see raspberrypi.stackexchange.com/a/60563/78211 – Fabian Apr 2 '18 at 11:45
  • @Fabian Yes, that like other references fails to mention the fact that on the Zero models the ACT led is on when the system is idle. I did get around to checking that first hand yesterday. I've left a comment there for Dmitry. – goldilocks Apr 2 '18 at 12:48
1

Your image is working, the green led flickering means that the rpi zero is successfully booting... so the problem is probably in your display mode or cable. Try this:

  1. insert the sd card into a computer
  2. open the 'boot' partition on the sd card. this partition will have files like overlays, kernel.img, bcm2708-rpi-0-w.dtb... It will likely be the only partition you can access.
  3. open the file config.txt.
  4. find the line(near the top) that says:

    #hdmi_safe=1

    and uncomment it so it reads

    hdmi_safe=1

    this will set the HDMI mode to "failsafe" settings.

  5. If you can not find that line, just add

    hdmi_safe=1

    to the bottom of the file.

  6. Also try un-commenting(removing the #) or adding a line that reads hdmi_force_hotplug=1. This will force HDMI output.

  7. save the file, eject the sd card, and plug it back into the pi. turn the pi on and make sure you have the right input mode slected on your tv. You most likely have multiple HDMI plugs on your tv, so try scrolling through all the input options(by pressing he input button) on your tv(ie HDMI1, HDMI2, ANALOG, CABLE, etc.), until you find the one your pi is plugged into.

Hope this helps!!!

see this to learn more about the config.txt file.

  • Thanks, scitronboy! You guys were a big help. If I may bend your ear once more, as you and godilocks have a ton more experience than me: I am building a small retro arcade, using a Pi Zero, as a goodbye gift at work. So this entire project is being done on my TV. It works perfectly now. But I fear that when my friend gets it home, they'll plug it into whatever TV he has and this won't work. I tried plugging this pi into 2 other TVs in my own house and it's pretty sketchy. One just keeps rebooting, the other just did the initial boot and then went blank before ever getting to ES. – Steve J Apr 3 '18 at 22:47
  • So if there is any thoughts about switching TVs or any ideas about recommenting those config files?? I don't know... thank you, though! – Steve J Apr 3 '18 at 22:53
  • @SteveJ , the monitor keeps rebooting or the pi keeps rebooting? and on the second monitor, could you actually see the boot log scrolling by on the screen, or did the monitor just turn on? could you give us a few more details? make sure your selecting the right input on your tv – scitronboy Apr 4 '18 at 15:48
  • Sure! Thanks for the response. I'm on a 15" hdtv, brand is element. Some cheap thing from Wal-Mart I got for the kids. – Steve J Apr 4 '18 at 22:26
  • The Pi is actually running great. No issues. I plugged in the HDMI first, then the controller... then the power source last. I even kept the tv's source on TV while I plugged it in. Once the Pi's green light stayed on, I switched the TV input over to HDMI 1 (the only HDMI port on this TV) – Steve J Apr 4 '18 at 22:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.