2

Suddenly I'm having issues starting downloads.

I'm using : sudo service transmission-daemon (start/stop/restart)

I looked at /var/log/daemon.log and found an error:

Couldn't save temporary file "/var/lib/transmission-daemon/.config/transmission-daemon/resume/(torrentName)": Permission denied (variant.c:1227)
Unable to save resume file: Permission denied (torrent.c:536)
Couldn't save temporary file "/var/lib/transmission-daemon/.config/transmission-daemon/torrents/(torrentName)": Permission denied (variant.c:1227)

Looking at those dirs are both empty with the same permissions:

$ ls -la /var/lib/transmission-daemon/.config/transmission-daemon/torrents/
total 8
drwxrwxr-x 2 transmission        transmission        4096 Oct  4  2016 .
drwsrwxr-x 5 debian-transmission debian-transmission 4096 Apr  1 18:30 ..

Looking at the process owner:

$ ps -aux | grep trans
debian-+  1900  0.0  0.6  29196  5796 ?        Ssl  18:33   0:00 /usr/bin/transmission-daemon -f --log-error

Can anyone help? Thanks.

1

On a whim, I tried changing the owner of the resume directory:

sudo chown debian-transmission:debian-transmission /var/lib/transmission-daemon/.config/transmission-daemon/resume

That did the trick. Parent directory's owner was debian-transmission and debian-+ was listed as the user of the daemon. I'm not 100% sure why this fixed it, but things are back up and running again.

  • Please accept your answer. Only this will finish the question and it will not pop up again months for months. – Ingo Dec 1 '19 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.