I have a raspberry Pi 3 Model B+ running Stretch OS dated 3-13-2018 and am having trouble getting the touchscreen portion of my new display a GeeekPi 7 inch TFT 1024X600 display working. I have the resolution set but cannot get the cursor to be controlled via the touchscreen. I have the micro USB attached from the Pi and have rebooted several times but still no work. This is my first attempt at using a Touchscreen Display. The Display is amazing but since I am trying to use this for a Auto Entertainment Center i need the touchscreen as I dont want to have to use a mouse and keyboard. The exact display I am speaking of is: https://www.amazon.com/gp/product/B075QCXLPF/ref=oh_aui_detailpage_o08_s02?ie=UTF8&psc=1 In the description it says (Extend Two USB HOST Ports;Resolution up to 1024 x 600; USB Capacitive touch control ;Free-driver, Plug and Play; ) So it came with no software and the wiki site only reflects directions on adjusting the resolution which I have working.

Does anyone know is there software that needs to be loaded in order for the touchscreen to work? Anyone with any idea on what I can try i am more then willing to try. Thank you Brian Zimmer bfpa40@gmail.com


My issue was with a faulty USB Cable, what clued me off was I plugged a USB Mouse into the 2-USB Ports on the Display and it wouldnt work while it would work when plugged directly into the Pi. So I swapped out the USb Cable feeding the Display and IT WORKED. Sometimes best to think in Simple terms.. KISS (Keep It Simple Stupid)

  • 1
    Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo Jan 20 '20 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.