0

I am fairly new to raspberry pi so if I am not providing enough information please let me know. Im working with a new Raspberry Pi 3.

My issue is that the command i2cdetect -y 1 is returning all addresses as active. I read online that you can perform a GPIO test when no devices are plugged into the raspberry pi. I ran the test using ./gpiotest and it reported that my pin 2, SDA.1, failed. I also ran gpio readall and it showed that my pin 2, SDA.1, is low when nothing is plugged into it.

I am not sure if this is a hardware or software issue. What I did later was that I downloaded and flashed a blank Raspbian image from https://www.raspberrypi.org/downloads/ . I ran the same test and my Pin 2 is still failing the GPIO test.

Something that is curious is that I have an Adafruit 3.5'' screen and it works fine with my raspberry pi. I would think that if pin 2 is messed up, the screen shouldn't work.

Aside from the screen, I have a mouse, keyboard, and HDMI linked screen to my raspberry pi.

If this is a hardware issue is there any way to work around it? For example, is there any way to deactivate SDA.1 and just have the PI read addresses from SDA.0?

I appreciate your feedback!


Edit: When I say Pin 2 above, I am refering to Pin 3 the SDA.1. Sorry for the confusion.

1

The symptoms indicate that something is pulling SDA to ground. You had nothing connected so it is not an external device.

Check around pin 3 for any debris. If you can't find any it sounds like the GPIO is broken. It can not be fixed and in that case the GPIO will not work in any mode.

Are you sure your screen actually uses pin 3?

  • Yes. In the above text, I meant the GPIO 2, which is Pin 3. The screen is connected to GPIO 2 and it works fine, but I tried connecting another component to the same GPIO 2, an Adafruit LED array, and it is not working. Both when the screen is connected and when it's not connected the gpio readall shows that GPIO 2 is malfunctioning, since it is LOW and the i2cdetect -y 1 returns all addresses as active. – David Brenes Apr 4 '18 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.