3

First, some background: the CIFS drive I am trying to mount: PASSPORT2TB is connected via USB to a small wifi AP running OpenWRT, and it is shared via the Samba server on that (OpenWRT) host. I want to connect to PASSPORT2TB from my two RPi boxes; one runs jessie, the other runs stretch. I do not have an entry in /etc/fstab for PASSPORT2TB on either of the RPis. RPi:stretch is a new install on a new 3B+; RPi:jessie was recently upgraded from wheezy, and has an operational mount point that has worked for... years.

Here's the exchange when I attempt to mount PASSPORT2TB from RPi:stretch:

sudo mount -t cifs //192.168.1.250/PASSPORT2TB ~/mntPassport
Password for root@//192.168.1.250/PASSPORT2TB:  ********
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I've searched for an answer, and tried the -o option as follows with no success (you may have to scroll horizontally to see the entire line):

sudo mount -t cifs //192.168.1.250/PASSPORT2B mntPassport -o guest,vers=1.0
Retrying with upper case share name
mount error(6): No such device or address
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
-------------------------------------
sudo mount -t cifs //192.168.1.250/PASSPORT2B mntPassport -o guest,vers=2.0
mount error(112): Host is down
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Anyone know what is causing this - or how to correct it?

5

Here's how to overcome this issue:

sudo mount //192.168.1.250/PASSPORT2TB ~/mntPassport -o username=guest,password=,vers=1.0

That said, be aware that there appear to be some "issues" and new twists in the code in Raspbian "Stretch":

  1. Whereas Jessie & earlier were happy with username or user, Stretch insists upon username
  2. The man page for mount.cifs states for the version option:

    vers=SMB protocol version. Allowed values are:
    
       ·   1.0 - The classic CIFS/SMBv1 protocol. This is the default.
    

But this is NOT the default, and therefore the man page is INCORRECT as vers=1.0 MUST be specified for this to work in Stretch. (see above)

  1. Using vers=2.0 or vers=3.0 will both fail on Stretch
  2. And finally, the error message provided by Stretch is useless:

    mount error(112): Host is down

-1

I just went through the same issue. My solution was to add ",vers=1.0" to the -o list of options. I know I am not supposed to say thanks in Stackexchange, but I found the solution in another post on SE- Debian.

This worked in fstab Jessie, but not Stretch: //nst-600nu/PUBLIC /mnt/nst-600 cifs username=guest,password=guest,workgroup=MSHOME,users,auto,_netdev,user_xattr 0 0

This works in Stretch: //nst-600nu/PUBLIC /mnt/nst-600 cifs username=guest,password=guest,workgroup=MSHOME,users,auto,_netdev,user_xattr,vers=1.0 0 0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.