2

It seems that my Raspberry PI 3B is very picky about which switches it works with when booting using PXE.

When I connect the PI to my regular non-POE switch, PXE boot works fine. When I connect it to my first POE switch, PXE does not work. At first, I thought my POE switch is damaged, so I bought a second one (completely different model and maufacturer) and tried it with that. But still the same problem. Most of the times, dnsmasq does not even log a DHCP request through these switches, and in rare cases it gets the request and sends 2 files through tftp and then no more files get requested.

But I know the POE switches are working quite well for everything else. If I connect my computer to it, i get internet connectivity and all this, if I connect a raspberry pi that boots from SD-card, it boots fine and gets internet connectivity as well.

So the issues are only related to PXE.

The funny part is, that when I do something like this:

Router -> POE-switch -> regular switch -> PI

PXE boot works again. It only does not work when the PI is connected directly to the POE switch.

I think the problem is not really that it's a POE-switch, I believe that the PI is just very picky with the switch. I bet there are regular switches out there that would not work as well, just because they do a tiny little thing different than the others.

But if that's true, I don't want to buy another switch, and then another switch until one works. Does anybody use PoE and PXE at the same time? If yes, what switch do you use?

I can tell you, these 2 don't:

  • edimax ES-5104PH
  • Autoeye 4-Port PoE switch

Notes I know that the PI does not support PoE without a splitter. I have a splitter and also tried it, but it does not make a difference. If i connect the PI with the splitter to a regular switch, PXE works. If i connect the PI with the splitter to a PoE switch, it doesn't. Sad story :(

  • Have you tried to turn off the power feature on the POE switch, then power the PI normally and see if PXE works that way? Some POE switches only support 100mb/s rate because they use some wires dedicated to power but the Pi 3 B+ (are you using model B or B+?) needs all 8 wires of an ethernet cable for data to support gigabit. That means there could be a problem with ethernet auto-negotiation at startup. – John Hawthorne Apr 7 '18 at 9:33
  • 1
    I can't turn off the power feature on both switches. But they're both IEEE 802.3af compliant, so there shouldn't be something unexpected going on for the PI. I have a B, but I bought a B+ just now, to test if it has the problem as well, and it does :( – Van Coding Apr 7 '18 at 9:59
  • 1
    UPDATE No the 3B+ does NOT have this problem! :) Only the 3B... which is sad, because the 3B's are currently very cheap where I live and the 3B+ has a much higher power usage. I plan to use 12 of them as wall-displays, so power-usage is not unimportant. – Van Coding Apr 7 '18 at 10:08
0

I have now bought the Ubiquity Edgeswitch, and with it PXE and PoE do work at the same time with the PI 3B. Sadly, the 3B+ does no longer work with this one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.