1

I am trying to install OpenCV on Raspberry Pi2 on raspbian stretch and python 2.7

when typing sudo apt-get install python-scipy I get the following error.

"Package python-scipy is not available, but is reffered to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source.

Does anyone have a solution for this?

Thank you :)

  • Have you run apt-get update recently? If that doesn't have any effect, could you include your /etc/apt/sources.list? – Aurora0001 Apr 9 '18 at 11:30
  • I uncomented a line of code in sources.list and that solvced it. Thank you! – jled Apr 9 '18 at 11:48
  • 1
    Feel free to post an answer below with what you did to resolve this question in case anyone else in future gets the same issue; good to hear you solved it. – Aurora0001 Apr 9 '18 at 11:51
  • in /etc/apt/sources.list I uncomented the 3rd line. deb raspbian.raspberrypi.org/raspbian stretch main contrib non-free rpi # Uncomment line below then 'apt-get update' to enable 'apt-get source' deb-src raspbian.raspberrypi.org/raspbian stretch main contrib non-free rpi – jled Apr 9 '18 at 13:36
  • You can post a full answer (rather than a comment) by clicking "Answer your Question" below. Once you post that, you'll then be able to accept it as an answer and mark this as resolved in a couple of days. – Aurora0001 Apr 9 '18 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.