0


I am planning to implement a camera video stream from the Raspberry Pi to its own Apache server. I trying to solve this for a week now and i am pretty frustrated by now. I came across this tutorial and i thought my problem was finally solved. I don't think the original author would answere me if I wrote him, since this tutorial is really old. So maybe one of you can help me with the problem. I did every step that was mentioned and got to the last step where i had to start the stream with the command on the bottom of the tutorial. The problem is that when I type it in and hit Enter, I get the following Error: -bash: ffmpeg: command not found.
I really hope you can help me with that.

  • Welcome! If you get the error "command not found" then the linux command whereis is your best friend, try whereis ffmpeg to find out if this command is available. But this is not RPi specific. – Fabian Apr 10 '18 at 20:48
0

You need to install ffmpeg on your system:

sudo apt-get install ffmpeg

However I suggest you have a look at the 'motion' package which will do this and a lot more: https://motion-project.github.io/

  • Thank you for your answere. Installing ffmpeg solved the problem. But now i face the next problem: When i try to view the stream in my browser it just shows a black image. The camera is working fine(I made a test photo). – Daniel M Apr 10 '18 at 20:33
  • Try using a different browser. I've noticed firefox works better for me. Don't forget to mark this answer as accepted (solved). – John Hawthorne Apr 10 '18 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.