2

I have followed the official guide (https://www.raspberrypi.org/documentation/hardware/raspberrypi/bootmodes/msd.md) to boot my Pi from a 8GB USB stick.

I have verified the correct bit is set in the OTP memory. I have copied a fresh download of Raspbian to the USB stick with Etcher.

Now when I insert the USB stick in the Pi (without any SD card) and power on, the first 5 sec nothing happens, only the red LED is burning. This is expected.

After 5 sec, I can see the activity LED on my USB stick flashing for approximately 2 sec, then it stops and no LEDs flash on the Pi / there is no output on the screen, and the Pi does not boot.

Are there any other steps I can take to troubleshoot this issue? What should the partitions on the USB stick look like? Is it connected to what model of USB stick I'm using? (Kingston Technology DT101 G2)

  • 1
    What happens the green (ACT) led on your raspberry pi? – scitronboy Apr 12 '18 at 20:31
  • 1
    Have you tried a different USB drive? Did you follow the troubleshooting tips here: raspberrypi.org/blog/pi-3-booting-part-i-usb-mass-storage-boot – Craig Apr 12 '18 at 20:37
  • What files can you see on your USB drive? – Jaromanda X Apr 12 '18 at 23:04
  • The green (ACT) LED doesn't do anything. On the usb drive I have a /boot and a /rootfs partition with all the necessary files as far as I can see. I'll try a different USB stick this evening. – Ruben Apr 13 '18 at 7:24
  • I have used a different USB stick with the same result... – Ruben Apr 13 '18 at 18:27
2

You should try a different USB drive. You've mentioned that you're using a "Kingston Technology DT101 G2". Perhaps coincidentally, a Kingston USB drive is mentioned in this raspberrypi.org blog post on "USB MASS STORAGE BOOT BETA" as an example of a USB drive that has a "very specific protocol requirement", and won't work with the new RPi system.

This same reference also lists several USB drives that have been tested, and found to work properly. After all the work you've put into this, why take chances?

  • I have used a different USB stick with the same result... – Ruben Apr 13 '18 at 18:27
  • I thought it was worth a try. I've got nothing else to offer - sorry. – Seamus Apr 13 '18 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.