I'm attempting to share the wifi connection of the onboard wifi chip (wlan0) with my other devices using a wifi adapter (wlan1). The problem I am currently facing is that the wifi adapter is not showing up as wlan1. It appears in lsusb as Bus 001 Device 008: ID 13b1:0042 Linksys but not when I run ifconfig. Only wlan0 appears.

I've looked in the following locations without any luck:

The current Raspbian version (one that comes with NOOBS) I am using also doesn't contain /lib/udev/rules.d/75-persistent-net-generator.rules which I see commonly discussed when the topic of two wifi adaptors is brought up on forums.

Any help or guidance with solving this would be appreciated.

  • 1
    "My goal is to implement this tutorial" do you want us to read the tutorial and guess WHAT you did - you are likely to get more response if you tell us WHAT you ACTUALLY did also tell us WHAT Raspbian.
    – Milliways
    Commented Apr 13, 2018 at 3:43
  • 1
    Remove that line and my question doesn't change. The wifi adapter is not showing up under wlan1.
    – user85004
    Commented Apr 13, 2018 at 14:07

1 Answer 1


ifconfig only shows interfaces that are in an "up" state. ifconfig -a will show all of them, but as per the man page:

This program is obsolete! For replacement check ip addr and ip link.

Which doesn't mean it is going anywhere, but you might as well use ip link, which will also show everything.

If it still doesn't show up, it's probably because of this -- note no available linux driver. That's unusual, but to spare yourself grief you should check around before buying. My recommendation about wifi drivers is to get them from a brick and mortar place close by that will take a return or exchange no questions asked within a short period of time.

However, grepping through the kernel source, I found the ID registered and "Linksys WUSB6100M" in corresponding comments. Unfortunately, it is for the ath10k_usb driver which

This module adds experimental support for USB bus. Currently work in progress and will not fully work.

These are not necessarily up to date though and "fully work" is ambiguous. Try lsmod | grep ath and see if anything shows up. If not, try sudo modprobe ath10k_usb.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.