0

I want to configure my raspberry pi zero w as a headless device so I don't have to buy keyboards, mice and adapters. To do so I want to ssh into it, turn on vnc server so I can control it from where I fancy at a time.

I have read many tutorials, forums and questions here; basically this is where I got so far:

  • Flashed raspbian stretch in the sd.
  • Edited cmdline.txt and config.txt.
  • Created a blank ssh file with no extension.
  • Plugged the pi into my tv to check if it boots, which it does.

The problem is that when I plug the raspberry into my PC (running windows 10, up to date). When I plug it, a message appears that a RNDIS/ ethernet device is being installed, but when it's done, another message tells me that the USB COM device is ready. In the device manager it doesn't appear as a RNDIS device either (see the screenshot below). And I tried anyway to connect to the raspberry via ssh but the host doesn't exist.

I connect the rpi with two usb, one for power and one for data (I read somewhere that windows might give up recognising the device if it hasn’t boot up when plugged). First I connect the power usb and when the led does not blink I connect the data usb. Windows is supposed to recognise the rpi as a rndis Ethernet device, and people seem to succeed, but I can’t. I have tried different computers, even a Mac, and different rpis with the same luck. Can anyone help me?

Thank you

Device manager window after installing the device

update The output of dmesg on Ubuntu (what changed after rpi was plugged): [ 1003.463748] usb 1-2: new full-speed USB device number 3 using ohci-pci [ 1003.955907] usb 1-2: config 2 interface 1 altsetting 0 endpoint 0x81 has invalid maxpacket 512, setting to 64 [ 1003.955909] usb 1-2: config 2 interface 1 altsetting 0 endpoint 0x1 has invalid maxpacket 512, setting to 64 [ 1003.967644] usb 1-2: config 1 interface 1 altsetting 1 endpoint 0x81 has invalid maxpacket 512, setting to 64 [ 1003.967646] usb 1-2: config 1 interface 1 altsetting 1 endpoint 0x1 has invalid maxpacket 512, setting to 64 [ 1003.991203] usb 1-2: New USB device found, idVendor=0525, idProduct=a4a2 [ 1003.991206] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0 [ 1003.991207] usb 1-2: Product: RNDIS/Ethernet Gadget [ 1003.991208] usb 1-2: Manufacturer: Linux 4.9.80+ with 20980000.usb [ 1004.826953] cdc_subset: probe of 1-2:1.0 failed with error -22 [ 1004.835520] cdc_subset 1-2:1.1 usb0: register 'cdc_subset' at usb-0000:00:06.0-2, Linux Device, 5e:d1:97:be:10:65 [ 1004.836005] usbcore: registered new interface driver cdc_subset [ 1004.875153] cdc_ether: probe of 1-2:1.0 failed with error -16 [ 1004.875166] usbcore: registered new interface driver cdc_ether [ 1004.932576] cdc_subset 1-2:1.1 enp0s6u2i1: renamed from usb0 [ 1005.496548] IPv6: ADDRCONF(NETDEV_UP): enp0s6u2i1: link is not ready [ 1005.496800] cdc_subset 1-2:1.1 enp0s6u2i1: kevent 12 may have been dropped [ 1022.527364] sched: RT throttling activated

  • I use Linux so I'm not familiar with Windows but how do you connect the rpi with your PC? Just with a USB cable? Don't know if windows can emulate a USB connection as ethernet in this case. Usually we use an USB to ethernet adapter. Isn't it possible to use wifi? – Ingo Apr 14 '18 at 8:11
  • I connect the rpi with two usb, one for power and one for data (I read somewhere that windows might give up recognising the device if it hasn’t boot up when plugged). First I connect the power usb and when the led does not blink I connect the data usb. Windows is supposed to recognise the rpi as a rndis Ethernet device, and people seem to succeed, but I can’t. I have tried different computers, even a Mac, and different rpis with the same luck. – Daniel Apr 14 '18 at 19:49
  • @Daniel what’s the output of ‘sudo dmesg’ on MacOS? – user2497 Apr 15 '18 at 16:28
  • I have updated the post with the output of dmesg on Ubuntu (I didn’t have access to a Mac) – Daniel Apr 17 '18 at 11:00
0

I got an RNDIS driver from a musical website and it worked fine. I also shared it on the blog. It's the driver issue for Windows 10 (it's not getting installed automatically). Even many people commented that it worked very well for them too. You can get the driver and how to install it on the Pi Zero W - Raspberry Pi Zero W Headless setup – Windows 10 RNDIS Driver issue resolved

This method is called as Ethernet over USB method as Pi Zero W doesn't have an Ethernet port. This driver makes the USB as an Ethernet for our applications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.