0

After cycling the power on the Raspberry Pi 3, if I try to ssh to it (from Ubuntu), I get a "Resource temporarily unavailable" response.

If I ping Ubuntu --> Pi 3, it just hangs.

If I leave it hanging, and then ping Ubuntu <-- Pi 3, packets start coming in both directions. I can then ssh just fine. The same thing happens when I reverse the order and ping Ubuntu <-- Pi 3 first. I also tried pinging only with ip addresses.

Why would ssh only work after pining from both directions? Every time I reset the power I have to do this. It's a pain because I can't use the Pi 3 in headless mode.

The output of ssh -vvv is below:

OpenSSH_6.6.1, OpenSSL 1.0.1f 6 Jan 2014
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to 192.168.2.6 [192.168.2.6] port 22.
debug1: connect to address 192.168.2.6 port 22: Resource temporarily unavailable
ssh: connect to host 192.168.2.6 port 22: Resource temporarily unavailable
  • Seems to be a problem with name resolution. Have you tried pinging with the ip address? – Ingo Apr 14 '18 at 16:45
  • Im already pinging using the ips. – Ben Yetton Apr 14 '18 at 18:04
  • Try using ssh -vv and paste in the output. – goldilocks Apr 15 '18 at 12:39
  • Added to the answer. – Ben Yetton Apr 16 '18 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.