0

I have a RPI 3 that I bought a year ago, and I have only used the HDMI out 3 times. After I worked on setting it up, I unplugged the HDMI until today. It gets through the text on the boot up, but never goes to the GUI.

But I can SSH into a command prompt with putty. And the RPI ends up on a fsck command on the main partition. And it always ends up fixing a dirty bit "0x41".

Even Xtightvnc runs and I can use VNC viewer to make a virtual screen. I really want the HDMI output back working. Any help is appreciated.

  • are you using the startx command? – scitronboy Apr 15 '18 at 18:15
  • there is no command prompt to write startx – user6481546 Apr 15 '18 at 18:21
  • 3
    You can't have bought a RPI 3 B+ a year ago as it only came out last month. You might want to correct that ... – John Hawthorne Apr 15 '18 at 19:40
1

SSH to raspberry pi using your credentials and type sudo raspi-config

This command will open up the raspberry pi configuration.

In this configuration screen, look for the option

enable boot to Desktop/Scratch.

In the Next screen, choose

Desktop Login as user 'Pi' at the graphical desktop

You'll be asked to reboot afterwards. And on the next boot, you will be logged in to LXDE desktop environment. And you can enjoy the GUI experience with raspberry pi.

  • please note the names of options like enable boot to ... are different on current versions of raspbian, but the function is still the same. For example, in current versions of raspbian, you'd go to boot options -> desktop / CLI -> Desktop. – scitronboy Apr 16 '18 at 1:03
  • OK, thank you. I've crossed checked the names and new ones are correctly mentioned by you. – Smshrimant Jul 25 '18 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.