0

I intend to setup static IP for my raspberry using jessie ver 8. I intend have a static IP to remote my computer to Rpi using VNC through a Ethernet cable so I can see my Rpi screen for this simple purpose, and the other plan is another static IP to connect wirelessly over a network which has a internet access(in short I like the Rpi has internet access). I understand this question had asked few times so I tried to gathered the past info and follow, but still I couldn't get the wireless connection to connect properly which mean it having trouble connecting to internet but it has no problem connect to local network when I tried to ping a local computer in the same network.

/etc/dhcpcd.conf

# A sample configuration for dhcpcd.
# See dhcpcd.conf(5) for details.

# Allow users of this group to interact with dhcpcd via the control socket.
#controlgroup wheel

# Inform the DHCP server of our hostname for DDNS.
hostname

# Use the hardware address of the interface for the Client ID.
clientid
# or
# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
#duid

# Persist interface configuration when dhcpcd exits.
persistent

# Rapid commit support.
# Safe to enable by default because it requires the equivalent option set
# on the server to actually work.
option rapid_commit

# A list of options to request from the DHCP server.
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
# Most distributions have NTP support.
option ntp_servers
# Respect the network MTU.
# Some interface drivers reset when changing the MTU so disabled by default.
#option interface_mtu

# A ServerID is required by RFC2131.
require dhcp_server_identifier

# Generate Stable Private IPv6 Addresses instead of hardware based ones
slaac private

# A hook script is provided to lookup the hostname if not set by the DHCP
# server, but it should not be run by default.
nohook lookup-hostname

interface eth0
static ip_address=192.168.11.100/24
static routers=192.168.0.1
static domain_name_servers=192.168.0.1

interface wlan0
static ip_address=172.20.11.100/24
static routers=172.20.0.1
static domain_name_servers=172.20.0.1

/etc/network/interfaces

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Is there something wrong written that why it isn't connecting to internet? Appreciate your help and thank you!

  • You have not provided any information. – Milliways Apr 16 '18 at 6:23
  • I put some more details. Hope it explained more. – sunny Apr 16 '18 at 6:34
  • 1
    172.20.11.100/24 is not an internal IP in your network. – hcheung Apr 16 '18 at 7:42
  • In addition to the comment from @hcheung: for wlan0 it should be something like 172.20.0.100/24, or the routers should be e.g. 172.20.11.1. Same for eth0. – Ingo Apr 17 '18 at 11:35
0

I think I figured it out but it work. I should leave the static routers and static domain_name_servers parameter blank, it automatically configure it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.