1

I am setting up a VPN router on the pi3 and would like to ask two things that I am stuck on.

  1. I would like to disable the onboard WiFi that is assigned to wlan0, as I have two external adapters i'd like to use, one of which is for the wifi. Can I do that somehow without actually disabling the wlan0 interface so I can use it for something else?

  2. My current wifi network is open type of network that you connect to and it redirects you to a website where you enter your username and password and it enables broadband. How do I actually enable this wifi network on wlan1 if it redirects you within the cli?

I have actually disabled the onboard using the config file. Now after plugging in the dongles they are automatically assigned to wlan0 and wlan1. So one dongle took over the onboard NIC's job on wlan0 and I have actually enabled the internet within the GUI and going onto the web. However, now the wlan1 automatically connects to the same network, as there are two Access Points in the corridor (I think). How can I disable the wlan1 to connect to the second access point?

Thanks for you help

2

Stretch includes predictable network interface names which have been used in other distributions for some time. This can be used to unambiguously identify/manage interfaces.

The Foundation decided to "Disable predictable network interface names for Ethernet devices" after only 3 weeks. There is an option under Advanced Options of raspi-config to toggle this setting.

The onboard WiFi of the Pi3 and PIZeroW which is connected over sdio will still use the name wlan0

See How to set up networking/WiFi Advanced dhcpcd Configuration discusses "disabling" interfaces and how to handle multiple wireless networks.

The 2nd part of your question is not a standard network feature. You should be able to do this with a script in a web server.

  • Thanks. I have actually disabled the onboard using the config file. Now afer plugging in the dongles they are automatically assigned to wlan0 and wlan1. So one dongle took over the onboard NIC's job on wlan0 and I have actually enabled the internet within the GUI and going onto the web. However, now the wlan1 automatically connects to the same network, as there are two Access Points in the corridor (I think). How can I disable the wlan1 to connect to the second access point? – Redundant Apr 18 '18 at 11:15
  • 1
    You obviously DID NOT enable predictable network interface because then you would have interfaces like wlx......... This is PRECISELY the problems predictable network interfaces are designed to solve – Milliways Apr 18 '18 at 11:33
1
  1. On a fresh flashed Raspbian is no wifi enabled. So simply do nothing with wifi and you haven't one.

  2. Configure your wifi with wpa_supplicant to wlan1 instead of wlan0. How to to that you will find many examples on this site. Then connect to your open network and it's done.

  • Thanks. I have actually disabled the onboard using the config file. Now afer plugging in the dongles they are automatically assigned to wlan0 and wlan1. So one dongle took over the onboard NIC's job on wlan0 and I have actually enabled the internet within the GUI and going onto the web. However, now the wlan1 automatically connects to the same network, as there are two Access Points in the corridor (I think). How can I disable the wlan1 to connect to the second access point? – Redundant Apr 18 '18 at 11:15
  • The Rasbpian installed with NOOBS 2.7 seems to enable WiFi by default. – Bob Brown Apr 18 '18 at 13:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.