1

I recently downloaded and installed a standard Raspbian OS environment on my Pi. On my Ubuntu Laptop, "Logout after inactivity" is a standard setting, which I like a lot.

This is not active on my Pi, and if I do nothing with my Pi for a long period of time, the display screen will go to sleep, but I'm still logged in when I move the mouse.

How can I configure my Pi to power save AND log me out at the same time?

Also more troubling, with my Ubuntu laptop, the hot key combination "Super+L" logs me out. or locks the screen instantly, this feature is not available on my Pi.

Is there a way for me to configure, or add this functionality to my Pi's OS environment? Thank you!

  • 1
    The default desktop environment (DE) on Raspbian is PIXEL, which is a Raspbian specific tweak of LXDE. On Ubuntu you are more likely using GNOME or KDE. You can install and use that instead of PIXEL if you like, but they use more resources and will leave you with less free RAM etc. on the relatively puny Pi. If you want to give PIXEL a chance, have a look at the LXDE documentation -- most of that should apply, and as far as I am aware PIXEL doesn't have much documentation of its own. – goldilocks Apr 19 '18 at 18:32
  • try xscreensaver, disable the "hacks" and setup the lock screen timeout `sudo apt-get install xscreensaver – rob Apr 20 '18 at 10:59
0

I have been looking up and down for lock screen settings. I can't seem to find any way to change the amount of time before it locks the screen. Raspberry Pi devs must properly document this feature. Finally, Here is a way to completely disable it :

NO SCREEN BLANKING, NO POWER SAVE MODE, NO screen lock.(MONITOR STAYS ON ALL THE TIME)

sudo nano ~/.config/lxsession/LXDE-pi/autostart

#Add these lines:
@xset s 0 0
@xset s noblank
@xset s noexpose
@xset dpms 0 0 0

#so it looks like this:
@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@xset s 0 0
@xset s noblank
@xset s noexpose
@xset dpms 0 0 0

#save with 'Ctrl' + 'x' key, then 'y', then 'enter' and then:
sudo reboot

You will reboot and you are done.

Here is another way to configure timeout. May help in your case.

Source: forum

Found this hidden thread recently :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.