I have an university project, with 4 raspberry pi 3 (starter kit). I've successfully set 1 as an AP, and 2 with client (all 3 has mosquitto installed), they works fine. The AP is next to the router, in another room. So the clients and the router are in different room.

The problem is the 4th pi... It does not see ANY wifi network. So I thinked this is a hardver problem, because the other 2 sees 6 wifi networks, also my laptop and mobile sees too, both my wifi (with mostly 4/5) and the pi's (mostly 3/5 or 2/5) and some neighbor's wifi (mostly with 1/5 signal streinght). So I went back to the university, I said the problem, then I got another pi.

That's pi's wifi also had the same problem. But we upgraded the included power adapter, because that too doesn't worked - LOL. However I tought now, it's an OS problem, so I went down to the satellite wifi, I connected via UTP cable, I updated, I saw it sees next to the satellite the wifi, after update I went back and same, it can't see. OK, then, again back to university another replacement.

This started better, because the OS had fault before the INIT... GOOGLEING... ok, format card, copy fresh NOOBS... FAIL, card is read-only. Well, I wasn't able to remove the read-only (this session only read only), however I fount an 32Gb own microSD, format, copy, done. But this has the same problem again. Can't see the WIFIs... (however, sometimes at least it came up the router's wifi, not like at the previous ones.)

Then I tried inserted an installed OS from one of the working one, but it still can't see. It's hard to believe, from 6 cards, there's 3 defected ones and ALL IS NEW! Anybody, has idea what's the problem? Is this really hardware issue? Maybe anything to try as last hope?

2 Answers 2


If you can physically swap all the parameters from working Pi's then it is a hardware fault with the pi/pis

But, you have to swap everything to prove the test. Including SD card, power supply(plus cable) and the physical location. Plus any devices you connecting including monitor, keyboard, mouse, etc.

Bad Pi hardware is very rare but it does happen.

  • 1
    but 3 times in a row? from 6 device? that's not rare! Apr 21, 2018 at 11:11
  • 1
    I can think one more thing which can cause similar problems, at STM32F4_DISCOVERY board has two versions, but there's nothing in the name which says which version do you have, but basically it's built with two different accelerometer sensors... And you was able to determinate which one you have if you look the shape of the sensor... Apr 21, 2018 at 13:06

I don't overview when and where the 4th RasPi doesn't work so I can't verify my idea about the error. But I had a similar problem that an additional device doesn't connect to the network but couldn't verify a hardware problem. The reason was simply that the pool of ip addresses from the DHCP server was used up and the new device doesn't could get an ip address. You may also check this.

  • This can't be the problem, because in that case my laptop and my mobile should not see Pi's AP, but it saw it. Also, if there are no more IPs in the DHCP pool, it should not shut down the wifi broadcasting, it's two different services, in that case simply it should connect to the network, but it should not get an IP address. Nov 4, 2019 at 11:58
  • Also, it wasn't able to see ANY network as I wrote, not only the Pi's AP. Nov 4, 2019 at 12:00
  • Of course, there's nothing to do with it, this is why I can't understand your answer, my problem is I can't see ANY WIFI network. And your answer says because maybe the DHCP IP pool is out of the addresses. And when I say "I can't see ANY WIFI network" I mean I did not reach even the state when I want to connect to a network, because I can't find ANY network to connect to. Nov 4, 2019 at 12:22
  • @golddragon007 Sorry, but I don't understand what you try to explain. I have read the question three and more times but can't take it together. You have a RPi 4B that simply cannot see any networks, isn't it? Then you have a problem only with the RPi 4B.
    – Ingo
    Nov 4, 2019 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.