2

I have the Pi 3 B+ and wanted to know if there was any way to turn of the need for the Wi-Fi localisation as when travelling around different countries and using my Pi as an access point I have keep changing it, whereas on the old Pi 3 B there was need to include this additional step? Hopefully someone may know what needs to be changed in order to stop the Pi from checking?

  • 1
    "I have keep changing it" Why? Do you get an error message? – Milliways Apr 20 '18 at 6:29
  • When traveling around and connect to a different country WiFi I guess some data is transferred between the access point and the WiFi usb on my Pi I have to select the WiFi country then reboot before it lets me choose a WiFi connection. – Daza85 Apr 20 '18 at 15:06
1

You can simply disable the wifi-country service with:

rpi3+ ~$ sudo systemctl disable wifi-country.service

But when I enable the service again it has no effect. systemctl status wifi-country.service tells me Wi-Fi is disabled because the country is not set but WiFi is always working. Seems to be a bug but that shouldn't matter you.

  • Thanks Ingo I will give that a go as I just want to be able to select a WiFi connection without having to add an additional step. Thanks – Daza85 Apr 20 '18 at 14:57
  • I have just tried this so forgot my WiFi connection then set a random country that’s not GB. Completed command sudo systemctl disable wifi-country.service then I’m unable to select any wifi access point 😩 – Daza85 Apr 20 '18 at 17:03
  • Should I remove the service so it doesn’t even start? – Daza85 Apr 20 '18 at 17:23
  • @Daza85 No, I wouldn't remove the service. There may be dependencies to other services. After reboot check with systemctl status wifi-country.service. It should be loaded; disabled and inactive (dead) without further messages. Seems we are on different software level. I use Raspbian Stretch Lite without GUI. – Ingo Apr 20 '18 at 21:37
0

This is purely speculation on my part, but the Foundation states "WiFi is disabled until wireless regulatory domain is set (Pi 3 B+ only)".

I assume this is a condition of WiFi certification.

On the Pi3 the WiFi was restricted to channels 1-11, unless a suitable wireless regulatory domain is set. This satisfied all domains, even the FCC, because these channels are permitted in all jurisdictions.

Unfortunately there is NO 5GHz band or set of channels which are universally supported, and many administrations have a number of other restrictions to minimise interference.

I would have suggested disable wifi-country.service, as suggested. This effectively just runs /usr/lib/raspberrypi-sys-mods/wifi-country which is a simple script to check /etc/wpa_supplicant/wpa_supplicant.conf to see if a country is specified.

I can't see anything which would actually check what country you are actually in, but as the nearest country is a 4 hour flight away I am not in a position to try.

I did try setting my country to GB and my WiFi (2.4GHz) works.

You problem may be simply selecting a regulatory domain which does not match the surrounding WiFi networks. The regulatory domain definitely does affect how the on-board WiFi chip operates.

  • Hi thanks for the reply i have been trying different things but if i was to give this to someone whom has limited knowledge i think changing the wifi country just causes issues with an additional step. So far i have found file responsible like you suggested and can see it is checking /etc/wpa_supplicant/wpa_supplicant.conf. So wondered if there was anyone whom knew how to alter the file so it checks it has nothing set? Basically work in reverse? – Daza85 Apr 21 '18 at 7:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.