1

My Pi 3 B+ suddenly stopped working while I was setting up a GPIO connection to an LED through a breadboard and it won't boot anymore. I formatted the SD card and put NOOBS 2.8 but it still won't boot. The red power LED is on but the yellow ACT LED does not blink. I don't get any display through the HDMI port.

I now have learned that I don't have a proper power supply. I used my phone charger but it's not a 2.5A as it should be. Is it a possible cause of this kind of issue? I had used this Pi a couple of times before with the same power supply and apparently it was working fine. It was giving me the thunderbolt sign from time to time though.

If I get a proper power supply, is there any chance for my Pi to work again? Is it possible that it's been permanently damaged by using an insufficient power supply?

Update

A friend of mine has a Pi 3 (not +) with a proper power supply.

  • I tried his power supply with my Pi: still no boot and no ACT LED blinking
  • I tried his SD card with my Pi: still no boot and no ACT LED blinking
  • I tried my SD card with his Pi: it works fine

I've called customer service of the online store from which I purchased my Pi and they confirmed it looks like the Pi itself has a failure and I'm going to return it.

  • So you are saying that with the exact same hardware, but with variously-flashed SD cards, the unit will not boot, right? I then have to ask if anything else changed. If you are not supplying a full 2.5 Amps but have added an Arduino board or higher-power WiFi adapter that needs power then perhaps the red light might stay on if the power is right on the edge of being sufficient. Have you tried disconnecting all USB devices? – SDsolar Apr 21 '18 at 0:06
  • Yes and I think I did the SD card flashing correctly because I had it working before. When the problem started I had actually less devices connected than before as I was using it headless (no keyboard, no display, no mouse) and was connecting to it by SSH. I should also add that the problem started around the time when I made my first GPIO connection. Is it possible that I've damaged it by doing my GPIO connection wrong? – Alex Marandon Apr 21 '18 at 1:43
2

The red light being on is definitely a good sign, however it may not tell the whole story. It usually means the regulator circuitry is getting enough power, even taking into account the loads imposed by the processor and USB devices.

It is not foolproof. Sometimes you will want to actually monitor the 5V pin with a multimeter to see if it is telling you the truth.

Taking your questions in order:

Yes, I agree with your approach of obtaining a 2.5A 5V power supply for the board. Especially if you have USB devices that require power.

Then: It is exceedingly rare for a Pi to be actually damaged by use of an insufficient power supply. It is simply more likely to just not work. The way to diagnose this is to try it with a 2.5A power supply.

-----------------

If it still doesn't work, then delve a little further:

NOTE that SD card slots have a limited lifetime (number of removals and insertions). I'm sure they can handle dozens but wouldn't hazard a guess beyond that.

Also, it is possible to cause the pins in the socket to become misaligned. Or even the metal shell around it. A visual inspection should help you determine if the card itself is making proper contact.

  • Thank you, I'll try a proper power supply and let you know the result. – Alex Marandon Apr 21 '18 at 1:46
2

I just faced a similar problem, and found this thread: STICKY: Is your Pi not booting? (The Boot Problems Sticky)

If you have a PI3B+, that, after some days or weeks of working, suddenly has stopped booting, then please check if there is still 3V3 on the system. There have been some reports of the 3V3 supply suddenly stopping working, often after shorting the 3V3 to GND, but in a few cases also spontaneously. The issue is under investigation. To check for the absence of 3V3 measure on the 3V3 GPIO pin,(pin 1, see https://www.raspberrypi.org/documentati ... /README.md) with the red lead of your meter and with the minus lead touching the metal shield of either the USB ports, the Ethernet port, or even the HDMI port, as all of these are connected to GND. Set you meter to DC Volt. Make sure the probe you are measuring with does not slip, and simultaneously touches any of the other GPIO pins, as that might instantly destroy your PI, especially shorting the 3V3 pin to the 5V pin will prove to be fatal. If the 3V3 supply has disappeared, then return the PI to the reseller.

In my case, checking the 3V3 pin as described confirmed that the unit was defective. So I think this may be it, you were right to return your Pi.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.