0

My new pi0w isn't connecting to my home wifi in a headless environment. Here's my set up:

$ ifconfig wlan0
wlan0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
    ether b8:27:eb:70:cb:b1  txqueuelen 1000  (Ethernet)
    RX packets 0  bytes 0 (0.0 B)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 0  bytes 0 (0.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

$ systemctl status dhcpcd
● dhcpcd.service - dhcpcd on all interfaces
   Loaded: loaded (/lib/systemd/system/dhcpcd.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2018-04-20 22:10:45 EDT; 6min ago
  Process: 259 ExecStart=/usr/lib/dhcpcd5/dhcpcd -q -b (code=exited, status=0/SUCCESS)
 Main PID: 275 (dhcpcd)
   CGroup: /system.slice/dhcpcd.service
       └─275 /sbin/dhcpcd -q -b

Apr 20 22:10:48 bramble1 dhcpcd[275]: wlan0: carrier lost
Apr 20 22:10:48 bramble1 dhcpcd[275]: wlan0: deleting address fe80::bb9:396e:9a4a:cfba
Apr 20 22:10:48 bramble1 dhcpcd[275]: usb0: soliciting a DHCP lease
Apr 20 22:10:49 bramble1 dhcpcd[275]: usb0: soliciting an IPv6 router
Apr 20 22:10:53 bramble1 dhcpcd[275]: usb0: probing for an IPv4LL address
Apr 20 22:10:59 bramble1 dhcpcd[275]: usb0: using IPv4LL address 169.254.14.36
Apr 20 22:10:59 bramble1 dhcpcd[275]: usb0: adding route to 169.254.0.0/16
Apr 20 22:10:59 bramble1 dhcpcd[275]: usb0: adding default route
Apr 20 22:10:59 bramble1 dhcpcd[275]: usb0: removing route to 169.254.0.0/16
Apr 20 22:11:02 bramble1 dhcpcd[275]: usb0: no IPv6 Routers available

My /etc/wpa_supplicant/wpa_supplicant.conf looks like:

country=US
update_config=1
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
network={
       ssid="xxxxxx"
       proto=RSN
       key_mgmt=WPA2-PSK
       pairwise=CCMP TKIP
       group=CCMP TKIP
       psk="xxxxxx"
}

and my /etc/network/interfaces looks like:

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
auto wlan0

iface lo inet loopback

allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

It's finding my relevant network when I run sudo id dev wlan0 scan:

BSS 30:46:9a:44:b9:38(on wlan0)
TSF: 0 usec (0d, 00:00:00)
freq: 2412
beacon interval: 100 TUs
capability: ESS Privacy ShortSlotTime (0x0411)
signal: -39.00 dBm
last seen: 0 ms ago
SSID: xxxxxxxx
Supported rates: 1.0* 2.0* 5.5 11.0 18.0 24.0 36.0 54.0
DS Parameter set: channel 1
ERP: Barker_Preamble_Mode
ERP D4.0: Barker_Preamble_Mode
RSN:     * Version: 1
     * Group cipher: CCMP
     * Pairwise ciphers: CCMP
     * Authentication suites: PSK
     * Capabilities: 16-PTKSA-RC 1-GTKSA-RC (0x000c)
Extended supported rates: 6.0 9.0 12.0 48.0
WPS:     * Version: 1.0
     * Wi-Fi Protected Setup State: 2 (Configured)
     * Selected Registrar: 0x0
     * Response Type: 3 (AP)
     * UUID: 3be17555-a17b-36d1-d6cb-d8633ca028e9
     * Manufacturer: NETGEAR, Inc.
     * Model: WNDR3400
     * Model Number: WNDR3400
     * Serial Number: 01
     * Primary Device Type: 6-0050f204-1
     * Device name: WNDR3400
     * Config methods: Label, PBC
     * RF Bands: 0x3
WMM:     * Parameter version 1
     * u-APSD
     * BE: CW 15-1023, AIFSN 3
     * BK: CW 15-1023, AIFSN 7
     * VI: CW 7-15, AIFSN 2, TXOP 3008 usec
     * VO: CW 3-7, AIFSN 2, TXOP 1504 usec

Any thoughts?

  • Your data looks different than mine (which works :) How did you set up your WiFi - through raspi-config, or manually? – Seamus Apr 21 '18 at 14:58
  • I manually set up my wpa_supplicant.conf file following this guide: youtube.com/watch?v=xj3MPmJhAPU – James Hartman Apr 21 '18 at 15:34
  • What does you give sudo iw dev wlan0 scan? Do you find your hotspot? – Ingo Apr 21 '18 at 19:38
  • @Ingo updated with relevant hotspot output – James Hartman Apr 21 '18 at 19:52
0

OK, with iw we know wifi is working. Seems there is only a problem with associating. Try to use minimal entries in wpa_supplicant. I'm not familiar with dhcpcd. I use systemd-networkd but when I use a fresh flashed Raspbian Stretch Lite 2018-04-18 and connect to wifi, there are no entries in /etc/network/interfaces. You may have a look at How do I set up networking/WiFi/static IP address?.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.