I am new to the PI World just yesterday I received my Pi3 Model B+.

I am facing an issue where pi show display on conventional 24" monitor but not my TV. I've tried both options I had, through a sony home theatre system and also directly to the TV.

Need Help




Can you specify a little bit more what procedure did you follow when connecting?

  • Try connecting the TV's HDMI before plugging in the power. When booting up, if the Raspberry Pi does not 'see' it is connected to image output, it disables it until you boot up again.

On your TV side:

  • Are you connecting it directly to the HDMI in port?
  • Are you selecting the right source with the remote?
  • Does it give you any indication?

Try ruling out these and we can concentrate on other possibilities.

| improve this answer | |
  • No, I tried that but did not work. – Rahil Jain Apr 23 '18 at 12:14
  • 1
    Please, describe better your TV and cabling. Are you using HDMI only or with an adapter? how long is the cable? are you connecting directly to the TV input (to troubleshoot avoid adding extra devices such as your home theater)? does your TV support at least 720p? are you setting the channel to the correct HDMI source before turning on the RPi? – xavigisbeg Apr 23 '18 at 14:08

Check out the config.txt file on your SD-card /boot partition.

Try setting:


try hdmi_drive=1 if it won't work with 2.

The /boot partition is fat32, so the file is accessible from Windows if you feel lost in Linux.

But DO NOT format your card when Windows asks.

And DO use a text-editor that knows the difference of Linux/Unix, and Microsoft line endings in text-files.

Notepad++ is a great editor for such things. It is still one of the best editors for Windows even if it looks old and dated.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.