1

In order to connect to a WPA-enterprise network (eduroam) I currently have to do the following (I am using Raspbian GNU/Linux 9 (stretch)):

Modify

/etc/network/interfaces

to include

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
 pre-up wpa_supplicant -B -Dwext -i wlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf
 post-down killall -q wpa_supplicant

and I add my network information to:

/etc/wpa_supplicant/wpa_supplicant.conf

when I restart the PI I need to kill the running wpa_supplicant:

ps -C wpa_supplicant
sudo kill $ProcessID

sudo rm /var/run/wpa_supplicant/wlan0

then I can connect to wifi by running wpa_supplicant manually:

sudo wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

So my question is then: How do I stop the network manager from starting its wpa_supplicant service and instead start the one which gets defined by /etc/wpa_supplicant/wpa_supplicant.conf

thanks in advance

Jesse

EDIT

reading through the link on setting up WIFI it is mentioned:

wpa_supplicant-"$interface".conf in /etc/wpa_supplicant/ e.g. wpa_supplicant-wlan0.conf will only be used by wlan0

so I copied my wpa_supplicant.conf to wpa_supplicant-wlan0.conf and removed my modifications to /etc/network/interfaces and after rebooting am able to automatically connect. This is a much simpler solution.

0

You don't mention which OS but "the network manager" for Raspbian Jessie and Stretch is dhcpcd any you have killed it by including dhcp in /etc/network/interfaces

Mind you it is unclear what, if anything what you have put in /etc/network/interfaces will actually do, as it does not correspond to ANY normal networking protocol.

See How to set up networking/WiFi

  • Ive updated my question to include the OS in question. Thank you for the link, ill read it through. The steps I mention are what I find online for how to connect to a wpa-enterprise network. if there is another way, im happy to hear it – Jesse RJ Apr 23 '18 at 9:55
  • reading through that link on setting up WIFI it is mentioned wpa_supplicant-"$interface".conf in /etc/wpa_supplicant/ e.g. wpa_supplicant-wlan0.conf will only be used by wlan0 so I copied my wpa_supplicant to wpa_supplicant-wlan0.conf and removed my modifications to /etc/network/interfaces and after rebooting am able to automatically connect. – Jesse RJ Apr 23 '18 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.