1

I have a question regards a field firmware update; namely a firmware update from 0.24.0.54xxx to 1.0.0.55xxx. What do I have to consider when doing this?

Which files do I have to update? overlays, system0/devtree, kernel.img?

  • it is unclear what you want to do that update upgrade doesn't – Milliways Apr 23 '18 at 22:35
  • Hans may not know to do a "sudo apt-get update && sudo apt-get upgrade" Right, Hans? – SDsolar Apr 24 '18 at 2:39
1

what do I have to consider when doing this?

It's very hard to give a comprehensive list including all the applications that might require device tree overlays. However, one thing you could do is check your current /boot/config.txt for dtoverlay entries that are not commented out. If there are you will probably know why, since by default there aren't any. Further, things that are actually problematized this way by an update would be exceptions and not the rule.

I don't know where you are getting the version numbers from; I'm guessing a distro package (I use the git repo). If so, then this should include an appropriate addition to /lib/modules to match any new kernel. If not, then you need to make sure that is done. Fortunately, the Pi kernel will boot without it, but functionality will be affected. If lsmod doesn't have any output, you are missing the correct modules directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.